xr_usb_serial_common: bump to 2023-03-31
Fix 6.1 kernel compile git log --oneline ecc6eb.. -- xr_usb_serial_common-1a/ 90ad530166f0 Support Linux 6.1 af618e2eded6 #45 Fix some warnings Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
This commit is contained in:
parent
e88b7d25a2
commit
19e926bc91
2 changed files with 3 additions and 45 deletions
|
@ -2,13 +2,13 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=usb-serial-xr_usb_serial_common
|
||||
PKG_SOURCE_DATE:=2022-03-30
|
||||
PKG_SOURCE_VERSION:=ecc6ebe0141b97942d774e6c6be37a330cc11a74
|
||||
PKG_SOURCE_DATE:=2023-03-21
|
||||
PKG_SOURCE_VERSION:=90ad530166f096347a5a57b6f9eb21c422a40fd9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/kasbert/epsolar-tracer
|
||||
PKG_MIRROR_HASH:=487c4259211411d3c435284016f90c6770539c0a6f904f3327f18381a33c23e3
|
||||
PKG_MIRROR_HASH:=0cea56120542d3d546028d17389a3419ca930448005a9208728c40583ccf027d
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
--- a/xr_usb_serial_common-1a/xr_usb_serial_common.c
|
||||
+++ b/xr_usb_serial_common-1a/xr_usb_serial_common.c
|
||||
@@ -258,7 +258,9 @@ static void xr_usb_serial_ctrl_irq(struct urb *urb)
|
||||
{
|
||||
struct xr_usb_serial *xr_usb_serial = urb->context;
|
||||
struct usb_cdc_notification *dr = urb->transfer_buffer;
|
||||
+#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 9, 0)
|
||||
struct tty_struct *tty;
|
||||
+#endif
|
||||
unsigned char *data;
|
||||
int newctrl;
|
||||
int retval;
|
||||
@@ -390,7 +392,9 @@ static int xr_usb_serial_submit_read_urbs(struct xr_usb_serial *xr_usb_serial, g
|
||||
}
|
||||
static void xr_usb_serial_process_read_urb(struct xr_usb_serial *xr_usb_serial, struct urb *urb)
|
||||
{
|
||||
+#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 9, 0)
|
||||
struct tty_struct *tty;
|
||||
+#endif
|
||||
if (!urb->actual_length)
|
||||
return;
|
||||
#if LINUX_VERSION_CODE > KERNEL_VERSION(3, 9, 0)
|
||||
@@ -465,7 +469,9 @@ static void xr_usb_serial_write_bulk(struct urb *urb)
|
||||
static void xr_usb_serial_softint(struct work_struct *work)
|
||||
{
|
||||
struct xr_usb_serial *xr_usb_serial = container_of(work, struct xr_usb_serial, work);
|
||||
+#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 9, 0)
|
||||
struct tty_struct *tty;
|
||||
+#endif
|
||||
|
||||
dev_vdbg(&xr_usb_serial->data->dev, "%s\n", __func__);
|
||||
#if LINUX_VERSION_CODE > KERNEL_VERSION(3, 9, 0)
|
||||
@@ -1631,7 +1637,9 @@ err_out:
|
||||
static int xr_usb_serial_reset_resume(struct usb_interface *intf)
|
||||
{
|
||||
struct xr_usb_serial *xr_usb_serial = usb_get_intfdata(intf);
|
||||
+#if LINUX_VERSION_CODE <= KERNEL_VERSION(3, 9, 0)
|
||||
struct tty_struct *tty;
|
||||
+#endif
|
||||
if (tty_port_initialized(&xr_usb_serial->port)){
|
||||
#if LINUX_VERSION_CODE > KERNEL_VERSION(3, 9, 0)
|
||||
tty_port_tty_hangup(&xr_usb_serial->port, false);
|
Loading…
Reference in a new issue