boost: Bump to version 1.77.0
This commit updates boost to version 1.77.0 More info about Boost 1.77.0 can be found at the usual place [1]. There are two new libraries in this version: * Describe [2]: A C++14 reflection library, from Peter Dimov. Provides macros for describing enumerators and struct/class members, and primitives for querying this information. * Lambda2 [3]: A C++14, dependency-free, single header lambda library, from Peter Dimov. Allows simple function objects to be constructed via expressions such as: _1 + 5, _1 % 2 == 0, _1 > _2, or _1 == ' ' || _1 == '\t'. [1]: https://www.boost.org/users/history/version_1_77_0.html [2]: https://www.boost.org/libs/describe/ [3]: https://www.boost.org/libs/lambda2/ Signed-off-by: Carlos Miguel Ferreira <carlosmf.pt@gmail.com>
This commit is contained in:
parent
862ff880a8
commit
1953240085
4 changed files with 6 additions and 46 deletions
|
@ -11,13 +11,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=boost
|
PKG_NAME:=boost
|
||||||
PKG_VERSION:=1.76.0
|
PKG_VERSION:=1.77.0
|
||||||
PKG_SOURCE_VERSION:=1_76_0
|
PKG_SOURCE_VERSION:=1_77_0
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)_$(PKG_SOURCE_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
|
PKG_SOURCE_URL:=@SF/$(PKG_NAME)/$(PKG_NAME)/$(PKG_VERSION) https://dl.bintray.com/boostorg/release/$(PKG_VERSION)/source/
|
||||||
PKG_HASH:=f0397ba6e982c4450f27bf32a2a83292aba035b827a5623a14636ea583318c41
|
PKG_HASH:=fc9f85fc030e233142908241af7a846e60630aa7388de9a5fafb1f3a26840854
|
||||||
|
|
||||||
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
|
PKG_MAINTAINER:=Carlos M. Ferreira <carlosmf.pt@gmail.com>
|
||||||
PKG_LICENSE:=BSL-1.0
|
PKG_LICENSE:=BSL-1.0
|
||||||
|
@ -42,7 +42,7 @@ define Package/boost/Default
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/boost/description
|
define Package/boost/description
|
||||||
This package provides the Boost v1.76.0 libraries.
|
This package provides the Boost v1.77.0 libraries.
|
||||||
Boost is a set of free, peer-reviewed, portable C++ source libraries.
|
Boost is a set of free, peer-reviewed, portable C++ source libraries.
|
||||||
|
|
||||||
This package provides the following run-time libraries:
|
This package provides the following run-time libraries:
|
||||||
|
@ -77,7 +77,7 @@ This package provides the following run-time libraries:
|
||||||
- wave
|
- wave
|
||||||
|
|
||||||
There are many more header-only libraries supported by Boost.
|
There are many more header-only libraries supported by Boost.
|
||||||
See more at http://www.boost.org/doc/libs/1_76_0/
|
See more at http://www.boost.org/doc/libs/1_77_0/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=boost/host
|
PKG_BUILD_DEPENDS:=boost/host
|
||||||
|
@ -342,7 +342,7 @@ $(eval $(call DefineBoostLibrary,coroutine,system chrono context thread,,!boost-
|
||||||
$(eval $(call DefineBoostLibrary,date_time))
|
$(eval $(call DefineBoostLibrary,date_time))
|
||||||
#$(eval $(call DefineBoostLibrary,exception,,))
|
#$(eval $(call DefineBoostLibrary,exception,,))
|
||||||
$(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclude))
|
$(eval $(call DefineBoostLibrary,fiber,coroutine filesystem,,!boost-fiber-exclude))
|
||||||
$(eval $(call DefineBoostLibrary,filesystem,system))
|
$(eval $(call DefineBoostLibrary,filesystem,system atomic))
|
||||||
$(eval $(call DefineBoostLibrary,graph,regex))
|
$(eval $(call DefineBoostLibrary,graph,regex))
|
||||||
$(eval $(call DefineBoostLibrary,iostreams,,,,zlib liblzma libbz2 libzstd))
|
$(eval $(call DefineBoostLibrary,iostreams,,,,zlib liblzma libbz2 libzstd))
|
||||||
$(eval $(call DefineBoostLibrary,json,container))
|
$(eval $(call DefineBoostLibrary,json,container))
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/boost/fiber/detail/cpu_relax.hpp
|
|
||||||
+++ b/boost/fiber/detail/cpu_relax.hpp
|
|
||||||
@@ -47,7 +47,7 @@ namespace detail {
|
|
||||||
# else
|
|
||||||
# define cpu_relax() asm volatile ("nop" ::: "memory");
|
|
||||||
# endif
|
|
||||||
-#elif BOOST_ARCH_MIPS && (__mips_isa_rev > 1) && !defined(_MIPS_ARCH_OCTEONP)
|
|
||||||
+#elif BOOST_ARCH_MIPS && (((__mips_isa_rev > 1) && defined(__mips32)) || ((__mips_isa_rev > 2) && defined(__mips64)))
|
|
||||||
# define cpu_relax() asm volatile ("pause" ::: "memory");
|
|
||||||
#elif BOOST_ARCH_PPC
|
|
||||||
// http://code.metager.de/source/xref/gnu/glibc/sysdeps/powerpc/sys/platform/ppc.h
|
|
|
@ -1,29 +0,0 @@
|
||||||
--- a/boost/regex/v5/mem_block_cache.hpp
|
|
||||||
+++ b/boost/regex/v5/mem_block_cache.hpp
|
|
||||||
@@ -85,10 +85,10 @@ struct mem_block_node
|
|
||||||
struct mem_block_cache
|
|
||||||
{
|
|
||||||
// this member has to be statically initialsed:
|
|
||||||
- mem_block_node* next;
|
|
||||||
- unsigned cached_blocks;
|
|
||||||
+ mem_block_node* next { nullptr };
|
|
||||||
+ unsigned cached_blocks { 0 };
|
|
||||||
#ifdef BOOST_HAS_THREADS
|
|
||||||
- boost::static_mutex mut;
|
|
||||||
+ std::mutex mut;
|
|
||||||
#endif
|
|
||||||
|
|
||||||
~mem_block_cache()
|
|
||||||
@@ -133,11 +133,7 @@ struct mem_block_cache
|
|
||||||
}
|
|
||||||
static mem_block_cache& instance()
|
|
||||||
{
|
|
||||||
-#ifdef BOOST_HAS_THREADS
|
|
||||||
- static mem_block_cache block_cache = { 0, 0, BOOST_STATIC_MUTEX_INIT, };
|
|
||||||
-#else
|
|
||||||
- static mem_block_cache block_cache = { 0, 0, };
|
|
||||||
-#endif
|
|
||||||
+ static mem_block_cache block_cache;
|
|
||||||
return block_cache;
|
|
||||||
}
|
|
||||||
};
|
|
Loading…
Reference in a new issue