lighttpd: update to lighttpd 1.4.71 release hash
remove patches included upstream Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
This commit is contained in:
parent
9f19a64e02
commit
19291ee195
3 changed files with 3 additions and 90 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lighttpd
|
||||
PKG_VERSION:=1.4.70
|
||||
PKG_VERSION:=1.4.71
|
||||
PKG_RELEASE:=1
|
||||
# release candidate ~rcX testing; remove for release
|
||||
#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
|
||||
PKG_HASH:=921ebe1cf4b6b9897e03779ab7a23a31f4ba40a1abe2067525c33cd3ce61fe85
|
||||
PKG_HASH:=b8b6915da20396fdc354df3324d5e440169b2e5ea7859e3a775213841325afac
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -9,7 +9,7 @@ Subject: [PATCH] [meson] mod_webdav_min w/o deps: xml2 sqlite3 uuid
|
|||
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -879,6 +879,16 @@ if libsasl.found()
|
||||
@@ -876,6 +876,16 @@ if libsasl.found()
|
||||
]
|
||||
endif
|
||||
|
||||
|
|
|
@ -1,87 +0,0 @@
|
|||
From 2892a7bf3f8ce92f41134fab25fbc2057f4a36bf Mon Sep 17 00:00:00 2001
|
||||
From: Glenn Strauss <gstrauss@gluelogic.com>
|
||||
Date: Wed, 10 May 2023 19:06:42 -0400
|
||||
Subject: [PATCH] [mod_h2] HTTP/2 separate module; no longer builtin
|
||||
|
||||
---
|
||||
src/CMakeLists.txt | 3 ---
|
||||
src/Makefile.am | 9 +++------
|
||||
src/SConscript | 4 +---
|
||||
src/meson.build | 3 ---
|
||||
4 files changed, 4 insertions(+), 15 deletions(-)
|
||||
|
||||
--- a/src/CMakeLists.txt
|
||||
+++ b/src/CMakeLists.txt
|
||||
@@ -922,10 +922,7 @@ set(SERVER_SRC
|
||||
response.c
|
||||
connections.c
|
||||
h1.c
|
||||
- h2.c
|
||||
sock_addr_cache.c
|
||||
- ls-hpack/lshpack.c
|
||||
- algo_xxhash.c
|
||||
fdevent_impl.c
|
||||
http_range.c
|
||||
network.c
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -70,12 +70,10 @@ common_src=base64.c buffer.c burl.c log.
|
||||
|
||||
common_src += fdevent_win32.c fs_win32.c
|
||||
|
||||
-src = server.c response.c connections.c h1.c h2.c \
|
||||
+src = server.c response.c connections.c h1.c \
|
||||
sock_addr_cache.c \
|
||||
network.c \
|
||||
network_write.c \
|
||||
- ls-hpack/lshpack.c \
|
||||
- algo_xxhash.c \
|
||||
fdevent_impl.c \
|
||||
http_range.c \
|
||||
data_config.c \
|
||||
@@ -428,6 +426,8 @@ lighttpd_LDADD = \
|
||||
$(FAM_LIBS) $(LIBEV_LIBS) $(LIBUNWIND_LIBS)
|
||||
lighttpd_LDFLAGS = -export-dynamic
|
||||
|
||||
+lighttpd_SOURCES += h2.c ls-hpack/lshpack.c algo_xxhash.c
|
||||
+lighttpd_LDADD += $(XXHASH_LIBS)
|
||||
if BUILD_WITH_MAXMINDDB
|
||||
lighttpd_SOURCES += mod_maxminddb.c
|
||||
lighttpd_LDADD += $(MAXMINDDB_LIB)
|
||||
@@ -489,9 +489,6 @@ lighttpd_SOURCES += mod_wolfssl.c
|
||||
lighttpd_CPPFLAGS += $(WOLFSSL_CFLAGS)
|
||||
lighttpd_LDADD += $(WOLFSSL_LIBS)
|
||||
endif
|
||||
-#(until switch to mod_h2)
|
||||
-#lighttpd_SOURCES += h2.c ls-hpack/lshpack.c algo_xxhash.c
|
||||
-#lighttpd_LDADD += $(XXHASH_LIBS)
|
||||
|
||||
else
|
||||
|
||||
--- a/src/SConscript
|
||||
+++ b/src/SConscript
|
||||
@@ -75,10 +75,8 @@ common_src = Split("base64.c buffer.c bu
|
||||
ck.c \
|
||||
")
|
||||
|
||||
-src = Split("server.c response.c connections.c h1.c h2.c \
|
||||
+src = Split("server.c response.c connections.c h1.c \
|
||||
sock_addr_cache.c \
|
||||
- ls-hpack/lshpack.c \
|
||||
- algo_xxhash.c \
|
||||
fdevent_impl.c \
|
||||
http_range.c \
|
||||
network.c \
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -560,10 +560,7 @@ main_src = files(
|
||||
'connections.c',
|
||||
'data_config.c',
|
||||
'h1.c',
|
||||
- 'h2.c',
|
||||
'sock_addr_cache.c',
|
||||
- 'ls-hpack/lshpack.c',
|
||||
- 'algo_xxhash.c',
|
||||
'fdevent_impl.c',
|
||||
'http_range.c',
|
||||
'network_write.c',
|
Loading…
Reference in a new issue