Merge pull request #3684 from TouchStar/luarock-fix-siteconfig
luarocks: Fix seeded uname (s/m) in site-config.lua
This commit is contained in:
commit
1741d090ef
2 changed files with 42 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=luarocks
|
||||
PKG_VERSION:=2.2.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_PROTO:=git
|
||||
|
@ -43,6 +43,10 @@ CONFIGURE_ARGS = \
|
|||
--sysconfdir=/etc \
|
||||
--with-lua=$(STAGING_DIR)/host
|
||||
|
||||
CONFIGURE_VARS = \
|
||||
LUAROCKS_UNAME_S="Linux" \
|
||||
LUAROCKS_UNAME_M="$(ARCH)"
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,build)
|
||||
endef
|
||||
|
|
|
@ -0,0 +1,37 @@
|
|||
Index: luarocks-2.2.2/configure
|
||||
===================================================================
|
||||
--- luarocks-2.2.2.orig/configure
|
||||
+++ luarocks-2.2.2/configure
|
||||
@@ -388,18 +388,22 @@ then
|
||||
fi
|
||||
|
||||
echo_n "Configuring for system... "
|
||||
-if uname -s
|
||||
-then
|
||||
- LUAROCKS_UNAME_S=`uname -s`
|
||||
-else
|
||||
- die "Could not determine operating system. 'uname -s' failed."
|
||||
+if [ -z "$LUAROCKS_UNAME_S" ]; then
|
||||
+ if uname -s
|
||||
+ then
|
||||
+ LUAROCKS_UNAME_S=`uname -s`
|
||||
+ else
|
||||
+ die "Could not determine operating system. 'uname -s' failed."
|
||||
+ fi
|
||||
fi
|
||||
echo_n "Configuring for architecture... "
|
||||
-if uname -m
|
||||
-then
|
||||
- LUAROCKS_UNAME_M=`uname -m`
|
||||
-else
|
||||
- die "Could not determine processor architecture. 'uname -m' failed."
|
||||
+if [ -z "$LUAROCKS_UNAME_M" ]; then
|
||||
+ if uname -m
|
||||
+ then
|
||||
+ LUAROCKS_UNAME_M=`uname -m`
|
||||
+ else
|
||||
+ die "Could not determine processor architecture. 'uname -m' failed."
|
||||
+ fi
|
||||
fi
|
||||
|
||||
for v in 5.1 5.2 5.3; do
|
Loading…
Reference in a new issue