zstd: Fix compilation on uClibc-ng
uClibc-ng defines __GLIBCC__ and does not compile in execinfo.h. Disable it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
4072e78dbe
commit
171c81db0a
2 changed files with 12 additions and 1 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zstd
|
PKG_NAME:=zstd
|
||||||
PKG_VERSION:=1.4.0
|
PKG_VERSION:=1.4.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://codeload.github.com/facebook/zstd/tar.gz/v$(PKG_VERSION)?
|
PKG_SOURCE_URL:=https://codeload.github.com/facebook/zstd/tar.gz/v$(PKG_VERSION)?
|
||||||
|
|
11
utils/zstd/patches/010-uClibc-ng.patch
Normal file
11
utils/zstd/patches/010-uClibc-ng.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/programs/fileio.c
|
||||||
|
+++ b/programs/fileio.c
|
||||||
|
@@ -175,7 +175,7 @@ static void clearHandler(void)
|
||||||
|
|
||||||
|
#if !defined(BACKTRACE_ENABLE)
|
||||||
|
/* automatic detector : backtrace enabled by default on linux+glibc and osx */
|
||||||
|
-# if (defined(__linux__) && defined(__GLIBC__)) \
|
||||||
|
+# if (defined(__linux__) && (defined(__GLIBC__) && !defined(__UCLIBC__))) \
|
||||||
|
|| (defined(__APPLE__) && defined(__MACH__))
|
||||||
|
# define BACKTRACE_ENABLE 1
|
||||||
|
# else
|
Loading…
Reference in a new issue