haproxy: Update HAProxy to v1.8.26
- Update haproxy download URL and hash Signed-off-by: Christian Lachner <gladiac@gmail.com>
This commit is contained in:
parent
dc09a37913
commit
16f1b537b3
3 changed files with 9 additions and 9 deletions
|
@ -10,12 +10,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=haproxy
|
||||
PKG_VERSION:=1.8.25
|
||||
PKG_VERSION:=1.8.26
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.haproxy.org/download/1.8/src/
|
||||
PKG_HASH:=62c0b77de2275a54a443a869947ddcca2bad7bdc1cafd804732a0e0d59b1708b
|
||||
PKG_HASH:=e3c2a81b6f26dcb736a34ebb5f134d3251ceccf30386214655fa7ed6d3afa400
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
#!/bin/bash
|
||||
|
||||
CLONEURL=http://git.haproxy.org/git/haproxy-1.8.git
|
||||
BASE_TAG=v1.8.25
|
||||
BASE_TAG=v1.8.26
|
||||
TMP_REPODIR=tmprepo
|
||||
PATCHESDIR=patches
|
||||
|
||||
|
|
|
@ -46,7 +46,7 @@
|
|||
goto mkcert_error;
|
||||
|
||||
/* set public key in the certificate */
|
||||
@@ -6383,7 +6395,7 @@ smp_fetch_ssl_x_notafter(const struct arg *args, struct sample *smp, const char
|
||||
@@ -6387,7 +6399,7 @@ smp_fetch_ssl_x_notafter(const struct arg *args, struct sample *smp, const char
|
||||
goto out;
|
||||
|
||||
smp_trash = get_trash_chunk();
|
||||
|
@ -55,7 +55,7 @@
|
|||
goto out;
|
||||
|
||||
smp->data.u.str = *smp_trash;
|
||||
@@ -6483,7 +6495,7 @@ smp_fetch_ssl_x_notbefore(const struct a
|
||||
@@ -6487,7 +6499,7 @@ smp_fetch_ssl_x_notbefore(const struct a
|
||||
goto out;
|
||||
|
||||
smp_trash = get_trash_chunk();
|
||||
|
@ -64,7 +64,7 @@
|
|||
goto out;
|
||||
|
||||
smp->data.u.str = *smp_trash;
|
||||
@@ -9054,7 +9066,9 @@ static void __ssl_sock_init(void)
|
||||
@@ -9068,7 +9080,9 @@ static void __ssl_sock_init(void)
|
||||
#endif
|
||||
|
||||
xprt_register(XPRT_SSL, &ssl_sock);
|
||||
|
@ -74,7 +74,7 @@
|
|||
#if (!defined(OPENSSL_NO_COMP) && !defined(SSL_OP_NO_COMPRESSION))
|
||||
cm = SSL_COMP_get_compression_methods();
|
||||
i = sk_SSL_COMP_num(cm);
|
||||
@@ -9063,7 +9077,7 @@ static void __ssl_sock_init(void)
|
||||
@@ -9077,7 +9091,7 @@ static void __ssl_sock_init(void)
|
||||
}
|
||||
#endif
|
||||
|
||||
|
@ -83,7 +83,7 @@
|
|||
ssl_locking_init();
|
||||
#endif
|
||||
#if (OPENSSL_VERSION_NUMBER >= 0x1000200fL && !defined OPENSSL_NO_TLSEXT && !defined OPENSSL_IS_BORINGSSL && !defined LIBRESSL_VERSION_NUMBER)
|
||||
@@ -9092,8 +9106,8 @@ static void __ssl_sock_init(void)
|
||||
@@ -9106,8 +9120,8 @@ static void __ssl_sock_init(void)
|
||||
#else /* OPENSSL_IS_BORINGSSL */
|
||||
OPENSSL_VERSION_TEXT
|
||||
"\nRunning on OpenSSL version : %s%s",
|
||||
|
@ -94,7 +94,7 @@
|
|||
#endif
|
||||
memprintf(&ptr, "%s\nOpenSSL library supports TLS extensions : "
|
||||
#if OPENSSL_VERSION_NUMBER < 0x00907000L
|
||||
@@ -9184,12 +9198,14 @@ static void __ssl_sock_deinit(void)
|
||||
@@ -9198,12 +9212,14 @@ static void __ssl_sock_deinit(void)
|
||||
}
|
||||
#endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue