mdnsresponder: Fix compilation with uClibc-ng

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2019-06-19 14:54:19 -07:00
parent d1517aa627
commit 16e5309750
2 changed files with 14 additions and 1 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mDNSResponder
PKG_VERSION:=IETF104
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://opensource.apple.com/tarballs/mDNSResponder/IETF/

View file

@ -0,0 +1,13 @@
--- a/mDNSShared/PlatformCommon.c
+++ b/mDNSShared/PlatformCommon.c
@@ -43,6 +43,10 @@
typedef unsigned int socklen_t;
#endif
+#ifndef TCP_NOTSENT_LOWAT
+#define TCP_NOTSENT_LOWAT 25
+#endif
+
#if MDNS_MALLOC_DEBUGGING
// We ONLY want this for malloc debugging--on a running production system we want to deal with
// malloc failures, not just die. There is a small performance penalty for enabling these options