net/pagekitec: Update to newest version
Drops a patch, adds support for a status file for health tracking. Signed-off-by: Karl Palsson <karlp@tweak.net.au>
This commit is contained in:
parent
407438796b
commit
1688807f18
2 changed files with 2 additions and 46 deletions
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pagekitec
|
||||
PKG_REV:=0.91.200218
|
||||
PKG_REV:=0.91.200311
|
||||
PKG_VERSION:=$(PKG_REV)C
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=2f560ae679775758b1b5e5f69cd4d82afa28339ee8ab6ee9e4af11daa6f8be77
|
||||
PKG_MIRROR_HASH:=3546e1b4b69eb8e4b914d2161cfaced8b6b81e0a978d95411bae25f3adea754f
|
||||
PKG_SOURCE_URL:=https://github.com/pagekite/libpagekite.git
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_VERSION:=v$(PKG_REV)
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
From 7b4587818564aa667f868249e9a8f1dc1d095fd3 Mon Sep 17 00:00:00 2001
|
||||
From: "Bjarni R. Einarsson" <bre@klaki.net>
|
||||
Date: Tue, 25 Feb 2020 16:10:11 +0000
|
||||
Subject: [PATCH] Omit redundant times when logging to syslog
|
||||
|
||||
---
|
||||
libpagekite/pklogging.c | 19 ++++++++++++++-----
|
||||
1 file changed, 14 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/libpagekite/pklogging.c b/libpagekite/pklogging.c
|
||||
index cf353f8..6129c30 100644
|
||||
--- a/libpagekite/pklogging.c
|
||||
+++ b/libpagekite/pklogging.c
|
||||
@@ -55,16 +55,25 @@ int pk_log(int level, const char* fmt, ...)
|
||||
#else
|
||||
struct timeval t;
|
||||
char tsbuf[30];
|
||||
+# ifdef HAVE_DS_LOG_FORMAT
|
||||
gettimeofday(&t, NULL);
|
||||
strftime(tsbuf, sizeof(tsbuf), "%Y-%m-%d %H:%M:%S", localtime(&t.tv_sec));
|
||||
-# ifdef HAVE_DS_LOG_FORMAT
|
||||
len = snprintf(output, 4000, "[%s.%03d][%x] ",
|
||||
tsbuf, (int)t.tv_usec / 1000, (int) pthread_self());
|
||||
# else
|
||||
- len = sprintf(output, "t=%s.%03d; ts=%x; tid=%x; ll=%x; msg=",
|
||||
- tsbuf, (int)t.tv_usec / 1000,
|
||||
- (int) time(0), (int) pthread_self(),
|
||||
- logged_lines++);
|
||||
+ if (log_file != NULL) {
|
||||
+ gettimeofday(&t, NULL);
|
||||
+ strftime(tsbuf, sizeof(tsbuf), "%Y-%m-%d %H:%M:%S", localtime(&t.tv_sec));
|
||||
+ len = sprintf(output, "t=%s.%03d; ts=%x; tid=%x; ll=%x; msg=",
|
||||
+ tsbuf, (int)t.tv_usec / 1000,
|
||||
+ (int) time(0), (int) pthread_self(),
|
||||
+ logged_lines++);
|
||||
+ }
|
||||
+ else {
|
||||
+ /* For syslog, we omit the times, syslog handles that. */
|
||||
+ len = sprintf(output, "tid=%x; ll=%x; msg=",
|
||||
+ (int) pthread_self(), logged_lines++);
|
||||
+ }
|
||||
# endif
|
||||
#endif
|
||||
va_start(args, fmt);
|
Loading…
Reference in a new issue