apr: Enable DSO and add several configure vars

Users have reported errors with Apache. Enable DSO to try to fix.

Most of these vars default to no since we're cross-compiling. Change them
to on since all the libc's that OpenWrt supports supports these. epoll for
example should have better stability.

Changed PKG_LICENSE to SPDX.

Slight cleanups.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2019-05-06 16:18:27 -07:00
parent 31e992cf01
commit 165f72234d
No known key found for this signature in database
GPG key ID: 36D31CFA845F0E3B
2 changed files with 15 additions and 9 deletions

View file

@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=apr
PKG_VERSION:=1.6.5
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@APACHE/apr/
PKG_HASH:=a67ca9fcf9c4ff59bce7f428a323c8b5e18667fdea7b0ebad47d194371b0a105
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
PKG_LICENSE:=Apache License
PKG_LICENSE:=Apache-2.0
PKG_FIXUP:=autoreconf
PKG_REMOVE_FILES:=aclocal.m4 build/ltmain.sh
@ -33,22 +34,27 @@ define Package/libapr
endef
TARGET_CFLAGS += $(FPIC)
TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
CONFIGURE_ARGS += \
--without-pic \
--with-devrandom=/dev/urandom \
--disable-dso \
$(call autoconf_bool,CONFIG_IPV6,ipv6)
# XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
CONFIGURE_VARS += \
ac_cv_sizeof_struct_iovec=1 \
ac_cv_struct_rlimit=yes \
apr_cv_process_shared_works=no \
apr_cv_mutex_robust_shared=no \
ac_cv_func_sem_open=yes \
ac_cv_func_pthread_mutexattr_setpshared=yes \
apr_cv_mutex_robust_shared=yes \
apr_cv_tcp_nodelay_with_cork=yes \
apr_cv_use_lfs64=yes \
LDFLAGS="$$$$LDFLAGS -lpthread" \
apr_cv_sock_cloexec=yes \
apr_cv_process_shared_works=yes \
apr_cv_mutex_recursive=yes \
apr_cv_epoll_create1=yes \
apr_cv_epoll=yes \
apr_cv_dup3=yes \
apr_cv_accept4=yes
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 $(1)/usr/lib $(1)/usr/lib/pkgconfig $(1)/usr/share/build-1

View file

@ -36,7 +36,7 @@ Index: apr-1.5.2/Makefile.in
include/private/apr_escape_test_char.h
DISTCLEAN_TARGETS = config.cache config.log config.status \
include/apr.h include/arch/unix/apr_private.h \
@@ -135,9 +134,9 @@ tools/gen_test_char.lo: tools/gen_test_c
@@ -138,9 +137,9 @@ tools/gen_test_char.lo: tools/gen_test_c
$(APR_MKDIR) tools
$(LT_COMPILE)