avrdude: move from oldpackages, update to latest version & build opts
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
426d1f12d1
commit
1637dcbf99
2 changed files with 72 additions and 0 deletions
54
utils/avrdude/Makefile
Normal file
54
utils/avrdude/Makefile
Normal file
|
@ -0,0 +1,54 @@
|
|||
#
|
||||
# Copyright (C) 2008-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=avrdude
|
||||
PKG_VERSION:=6.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/avrdude
|
||||
PKG_MD5SUM:=9db8c25b935d34234b9b1ba16ad55fd5
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/avrdude
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=AVR Downloader/UploaDEr
|
||||
URL:=http://www.nongnu.org/avrdude/
|
||||
DEPENDS:=+libncurses +libreadline +libusb-compat +libftdi1
|
||||
endef
|
||||
|
||||
define Package/avrdude/description
|
||||
AVRDUDE is a full featured program for programming Atmel's AVR CPU's.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
--disable-doc \
|
||||
--disable-parport \
|
||||
|
||||
define Package/avrdude/conffiles
|
||||
/etc/avrdude.conf
|
||||
endef
|
||||
|
||||
define Package/avrdude/install
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/avrdude.conf $(1)/etc/
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/avrdude $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,avrdude))
|
18
utils/avrdude/patches/010-configure-fixups.patch
Normal file
18
utils/avrdude/patches/010-configure-fixups.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -35,6 +35,7 @@ AC_CONFIG_HEADERS(ac_cfg.h)
|
||||
|
||||
# Checks for programs.
|
||||
AC_PROG_CC
|
||||
+AC_PROG_CPP
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_SED
|
||||
AC_PROG_YACC
|
||||
@@ -183,6 +184,7 @@ fi
|
||||
AC_SUBST(LIBPTHREAD, $LIBPTHREAD)
|
||||
# Checks for header files.
|
||||
AC_CHECK_HEADERS([limits.h stdlib.h string.h])
|
||||
+AC_CHECK_HEADERS([inttypes.h stdint.h])
|
||||
AC_CHECK_HEADERS([fcntl.h sys/ioctl.h sys/time.h termios.h unistd.h])
|
||||
AC_CHECK_HEADERS([ddk/hidsdi.h],,,[#include <windows.h>
|
||||
#include <setupapi.h>])
|
Loading…
Reference in a new issue