diff --git a/lang/python/Makefile b/lang/python/Makefile
index 39a1da622..92271ba9f 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -97,13 +97,11 @@ CONFIGURE_ARGS+= \
 	CONFIG_SITE="$(PKG_BUILD_DIR)/config.site" \
 	OPT="$(TARGET_CFLAGS)"
 
-define Hooks/Configure/Pre/ConfigSiteInstall
+define Build/Prepare
+	$(call Build/Prepare/Default)
 	$(CP) ./files/config.site $(PKG_BUILD_DIR)/config.site
 endef
 
-Hooks/Configure/Pre+=\
-	Hooks/Configure/Pre/ConfigSiteInstall
-
 define Build/InstallDev
 	$(INSTALL_DIR) $(STAGING_DIR)/mk/
 	$(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/