fakepop: fix compilation with PKG_ASLR
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
f53cd4232a
commit
15d2ed15ca
2 changed files with 14 additions and 1 deletions
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=fakepop
|
PKG_NAME:=fakepop
|
||||||
PKG_VERSION:=11
|
PKG_VERSION:=11
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_MAINTAINER:=Marc Egerton <foxtrot@realloc.me>
|
PKG_MAINTAINER:=Marc Egerton <foxtrot@realloc.me>
|
||||||
PKG_LICENSE:=GPL-3.0-or-later
|
PKG_LICENSE:=GPL-3.0-or-later
|
||||||
|
|
13
net/fakepop/patches/010-fPIC.patch
Normal file
13
net/fakepop/patches/010-fPIC.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -2,8 +2,8 @@
|
||||||
|
|
||||||
|
GLIB_CFLAGS = $(shell pkg-config --cflags glib-2.0)
|
||||||
|
GLIB_LDFLAGS = $(shell pkg-config --libs glib-2.0)
|
||||||
|
-CFLAGS = -D_GNU_SOURCE -Wall -O2 $(GLIB_CFLAGS)
|
||||||
|
-LDLIBS = $(GLIB_LDFLAGS)
|
||||||
|
+CFLAGS += $(GLIB_CFLAGS)
|
||||||
|
+LDLIBS += $(GLIB_LDFLAGS)
|
||||||
|
|
||||||
|
all: fakepop
|
||||||
|
|
Loading…
Reference in a new issue