Merge pull request #20480 from gstrauss/lighttpd-1.4.69
lighttpd: update to lighttpd 1.4.69 release hash
This commit is contained in:
commit
15b1fb247d
3 changed files with 31 additions and 21 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lighttpd
|
||||
PKG_VERSION:=1.4.68
|
||||
PKG_VERSION:=1.4.69
|
||||
PKG_RELEASE:=1
|
||||
# release candidate ~rcX testing; remove for release
|
||||
#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
|
||||
PKG_HASH:=e56f37ae52b63e1ada4d76ce78005affb6e56eea2f6bdb0ce17d6d36e9583384
|
||||
PKG_HASH:=16ac8db95e719629ba61949b99f8a26feba946a81d185215b28379bb4116b0b4
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
@ -270,6 +270,7 @@ $(eval $(call BuildPlugin,vhostdb_ldap,Virtual Host Database (LDAP),lighttpd-mod
|
|||
$(eval $(call BuildPlugin,vhostdb_mysql,Virtual Host Database (MariaDB),lighttpd-mod-vhostdb +PACKAGE_lighttpd-mod-vhostdb_mysql:libmariadb,30))
|
||||
$(eval $(call BuildPlugin,vhostdb_pgsql,Virtual Host Database (PostgreSQL),lighttpd-mod-vhostdb +PACKAGE_lighttpd-mod-vhostdb_pgsql:libpq,30))
|
||||
$(eval $(call BuildPlugin,webdav,WebDAV,+PACKAGE_lighttpd-mod-webdav:libsqlite3 +PACKAGE_lighttpd-mod-webdav:libuuid +PACKAGE_lighttpd-mod-webdav:libxml2,30))
|
||||
$(eval $(call BuildPlugin,webdav_min,WebDAV,,30))
|
||||
$(eval $(call BuildPlugin,wolfssl,TLS using wolfssl,@LIGHTTPD_SSL +PACKAGE_lighttpd-mod-wolfssl:libwolfssl,30))
|
||||
$(eval $(call BuildPlugin,wstunnel,Websocket tunneling,$(if $(cryptolib),+PACKAGE_lighttpd-mod-wstunnel:$(cryptolib),),30))
|
||||
|
||||
|
|
28
net/lighttpd/patches/020-meson-mod_webdav_min.patch
Normal file
28
net/lighttpd/patches/020-meson-mod_webdav_min.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
From fe6895e5eb2c17ddad6e95faaac7d56d4dd73256 Mon Sep 17 00:00:00 2001
|
||||
From: Glenn Strauss <gstrauss@gluelogic.com>
|
||||
Date: Fri, 20 Jan 2023 18:48:14 -0500
|
||||
Subject: [PATCH] [meson] mod_webdav_min w/o deps: xml2 sqlite3 uuid
|
||||
|
||||
---
|
||||
src/meson.build | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -865,6 +865,16 @@ if libsasl.found()
|
||||
]
|
||||
endif
|
||||
|
||||
+modules += [
|
||||
+ [ 'mod_webdav_min', [ 'mod_webdav.c' ],
|
||||
+ [ libelftc,
|
||||
+ declare_dependency(compile_args: [
|
||||
+ '-DMOD_WEBDAV_BUILD_MINIMAL',
|
||||
+ '-Dmod_webdav_plugin_init=mod_webdav_min_plugin_init' ] )
|
||||
+ ]
|
||||
+ ]
|
||||
+]
|
||||
+
|
||||
foreach mod: modules
|
||||
mod_name = mod.get(0)
|
||||
mod_sources = mod.get(1)
|
|
@ -1,19 +0,0 @@
|
|||
From d809433d6d900e899f796606b11bdc6a73413ac5 Mon Sep 17 00:00:00 2001
|
||||
From: Glenn Strauss <gstrauss@gluelogic.com>
|
||||
Date: Tue, 3 Jan 2023 17:50:16 -0500
|
||||
Subject: [PATCH] [meson] remove t/test_mod_evasive.c
|
||||
|
||||
---
|
||||
src/meson.build | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -721,7 +721,6 @@ test('test_mod', executable('test_mod',
|
||||
't/test_mod.c',
|
||||
't/test_mod_access.c',
|
||||
't/test_mod_alias.c',
|
||||
- 't/test_mod_evasive.c',
|
||||
't/test_mod_evhost.c',
|
||||
't/test_mod_indexfile.c',
|
||||
't/test_mod_simple_vhost.c',
|
Loading…
Reference in a new issue