sumo: update to 0.23
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
e44e5d4ad7
commit
159f613941
3 changed files with 20 additions and 4 deletions
|
@ -8,23 +8,25 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sumo
|
||||
PKG_VERSION:=0.22.0
|
||||
PKG_VERSION:=0.23.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/sumo
|
||||
PKG_MD5SUM:=d239a3f94fdb905fdaf1648f2b71fd42
|
||||
PKG_MD5SUM:=0df95a449d44808b8d3677af086e1af1
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-xerces-includes=$(STAGING_DIR)/usr/include/xercesc \
|
||||
--with-xerces=$(STAGING_DIR)/usr \
|
||||
--disable-debug \
|
||||
--disable-dependency-tracking \
|
||||
--disable-silent-rules
|
||||
|
|
|
@ -3,4 +3,4 @@
|
|||
|
||||
SUMO_HOME=/usr/share/sumo sumo-bin $@
|
||||
|
||||
exit 0
|
||||
exit $?
|
||||
|
|
14
utils/sumo/patches/100-configure_fix.patch
Normal file
14
utils/sumo/patches/100-configure_fix.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -13,11 +13,6 @@ AC_LANG([C++])
|
||||
|
||||
dnl the debug check has to be made before the program checks
|
||||
dnl because it modifies CXXFLAGS
|
||||
-if test x$CXX = xclang++; then
|
||||
- CXXFLAGS="-msse2 $CXXFLAGS"
|
||||
-else
|
||||
- CXXFLAGS="-msse2 -mfpmath=sse $CXXFLAGS"
|
||||
-fi
|
||||
AC_ARG_ENABLE([debug], [AS_HELP_STRING([--enable-debug],[enable sumo debugging code [default=no].])])
|
||||
if test x$enable_debug = xyes; then
|
||||
AC_DEFINE(_DEBUG, 1, [Define to 1 in order to enable sumo debugging code.])
|
Loading…
Reference in a new issue