commit
14df7d2ee9
4 changed files with 18 additions and 125 deletions
|
@ -8,23 +8,19 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=avahi
|
||||
PKG_VERSION:=0.7
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=0.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION) \
|
||||
https://avahi.org/download
|
||||
PKG_HASH:=57a99b5dfe7fdae794e3d1ee7a62973a368e91e414bd0dfa5d84434de5b14804
|
||||
PKG_HASH:=060309d7a333d38d951bc27598c677af1796934dbd98e1024e7ad8de798fedda
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_CPE_ID:=cpe:/a:avahi:avahi
|
||||
|
||||
PKG_BUILD_DEPENDS:=intltool/host
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_REMOVE_FILES:=autogen.sh
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
|
@ -255,22 +251,24 @@ $(call Package/avahi/Default/description)
|
|||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC) -DGETTEXT_PACKAGE
|
||||
TARGET_LDFLAGS += $(if $(CONFIG_SSP_SUPPORT),-lssp_nonshared)
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-glib \
|
||||
--disable-gobject \
|
||||
--disable-introspection \
|
||||
--disable-qt3 \
|
||||
--disable-qt4 \
|
||||
--disable-qt5 \
|
||||
--disable-gtk \
|
||||
--disable-gtk3 \
|
||||
--with-xml=expat \
|
||||
--disable-dbm \
|
||||
--enable-gdbm \
|
||||
--enable-libdaemon \
|
||||
--disable-libevent \
|
||||
--disable-python \
|
||||
--disable-pygtk \
|
||||
--disable-python-dbus \
|
||||
--disable-mono \
|
||||
--disable-monodoc \
|
||||
|
@ -284,18 +282,16 @@ CONFIGURE_ARGS+= \
|
|||
--disable-doxygen-html \
|
||||
--disable-doxygen-ps \
|
||||
--disable-doxygen-pdf \
|
||||
--disable-manpages \
|
||||
--disable-xmltoman \
|
||||
--disable-tests \
|
||||
--with-xml=expat \
|
||||
--with-distro=none \
|
||||
--with-avahi-user=nobody \
|
||||
--with-avahi-group=nogroup \
|
||||
--with-autoipd-user=nobody \
|
||||
--with-autoipd-group=nogroup
|
||||
|
||||
ifneq ($(CONFIG_SSP_SUPPORT),y)
|
||||
CONFIGURE_ARGS+= \
|
||||
--disable-stack-protector
|
||||
endif
|
||||
|
||||
ifeq ($(BUILD_VARIANT),dbus)
|
||||
ifneq ($(CONFIG_PACKAGE_libavahi-compat-libdnssd),)
|
||||
CONFIGURE_ARGS += \
|
||||
|
@ -310,7 +306,7 @@ endif
|
|||
|
||||
CONFIGURE_VARS+= \
|
||||
CFLAGS="$$$$CFLAGS -DNDEBUG -DDISABLE_SYSTEMD" \
|
||||
ac_cv_header_sys_capability_h=no \
|
||||
ac_cv_header_sys_capability_h=no
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
|
|
|
@ -9,7 +9,7 @@ proto_autoip_setup() {
|
|||
local iface="$2"
|
||||
|
||||
proto_export "INTERFACE=$config"
|
||||
proto_run_command "$config" avahi-autoipd $iface
|
||||
proto_run_command "$config" avahi-autoipd "$iface"
|
||||
}
|
||||
|
||||
proto_autoip_teardown() {
|
||||
|
|
|
@ -1,88 +0,0 @@
|
|||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 8234d69..156d4c4 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -75,8 +75,7 @@ SUBDIRS = \
|
||||
avahi-compat-howl \
|
||||
avahi-autoipd \
|
||||
avahi-ui \
|
||||
- avahi-ui-sharp \
|
||||
- po
|
||||
+ avahi-ui-sharp
|
||||
|
||||
DX_INPUT = \
|
||||
$(srcdir)/avahi-common/address.h \
|
||||
diff --git a/avahi-python/avahi-discover/Makefile.am b/avahi-python/avahi-discover/Makefile.am
|
||||
index 5fc4b25..4c39d3d 100644
|
||||
--- a/avahi-python/avahi-discover/Makefile.am
|
||||
+++ b/avahi-python/avahi-discover/Makefile.am
|
||||
@@ -38,7 +38,6 @@ if HAVE_GDBM
|
||||
pythonscripts += \
|
||||
avahi-discover
|
||||
desktop_DATA += avahi-discover.desktop
|
||||
-@INTLTOOL_DESKTOP_RULE@
|
||||
avahi_discover_PYTHON += __init__.py
|
||||
endif
|
||||
|
||||
@@ -46,7 +45,6 @@ if HAVE_DBM
|
||||
pythonscripts += \
|
||||
avahi-discover
|
||||
desktop_DATA += avahi-discover.desktop
|
||||
-@INTLTOOL_DESKTOP_RULE@
|
||||
avahi_discover_PYTHON += __init__.py
|
||||
endif
|
||||
|
||||
diff --git a/avahi-ui/Makefile.am b/avahi-ui/Makefile.am
|
||||
index 238d43a..65a147a 100644
|
||||
--- a/avahi-ui/Makefile.am
|
||||
+++ b/avahi-ui/Makefile.am
|
||||
@@ -80,7 +80,6 @@ endif
|
||||
|
||||
bin_PROGRAMS = bssh
|
||||
desktop_DATA += bssh.desktop bvnc.desktop
|
||||
-@INTLTOOL_DESKTOP_RULE@
|
||||
|
||||
bssh_SOURCES = bssh.c
|
||||
|
||||
@@ -108,6 +107,4 @@ endif # HAVE_GLIB
|
||||
endif
|
||||
endif
|
||||
|
||||
-@INTLTOOL_DESKTOP_RULE@
|
||||
-
|
||||
CLEANFILES = $(desktop_DATA) $(desktop_DATA_in)
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 6678971..00dac6e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -23,7 +23,7 @@ AC_INIT([avahi],[0.7],[avahi (at) lists (dot) freedesktop (dot) org])
|
||||
AC_CONFIG_SRCDIR([avahi-core/server.c])
|
||||
AC_CONFIG_MACRO_DIR([common])
|
||||
AC_CONFIG_HEADERS([config.h])
|
||||
-AM_INIT_AUTOMAKE([foreign 1.11 -Wall -Wno-portability silent-rules tar-pax])
|
||||
+AM_INIT_AUTOMAKE([foreign 1.11 -Wall -Wno-portability tar-pax])
|
||||
|
||||
AC_SUBST(PACKAGE_URL, [http://avahi.org/])
|
||||
|
||||
@@ -43,8 +43,6 @@ AC_SUBST(HOWL_COMPAT_VERSION, [0.9.8])
|
||||
|
||||
AC_CANONICAL_HOST
|
||||
|
||||
-AM_SILENT_RULES([yes])
|
||||
-
|
||||
AC_CHECK_PROG([STOW], [stow], [yes], [no])
|
||||
|
||||
AS_IF([test "x$STOW" = "xyes" && test -d /usr/local/stow], [
|
||||
@@ -413,12 +411,6 @@ if test "x$have_kqueue" = "xyes" ; then
|
||||
AC_DEFINE([HAVE_KQUEUE], 1, [Enable BSD kqueue() usage])
|
||||
fi
|
||||
|
||||
-IT_PROG_INTLTOOL([0.35.0])
|
||||
-GETTEXT_PACKAGE=avahi
|
||||
-AC_SUBST([GETTEXT_PACKAGE])
|
||||
-AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[Gettext package])
|
||||
-AM_GLIB_GNU_GETTEXT
|
||||
-
|
||||
avahilocaledir='${prefix}/${DATADIRNAME}/locale'
|
||||
AC_SUBST(avahilocaledir)
|
||||
|
|
@ -1,26 +1,11 @@
|
|||
From ef0ea001f6dd13d6a2e0bc17d13f595d2829f8a8 Mon Sep 17 00:00:00 2001
|
||||
From: Jeremiah McConnell <miah@miah.com>
|
||||
Date: Fri, 15 Jun 2018 11:31:10 -0600
|
||||
Subject: [PATCH] move runtime_dir to /var/run
|
||||
|
||||
Upstream transitioned to using /run as runtime_dir for 0.7. Revert
|
||||
that change for procd compatibility.
|
||||
|
||||
Signed-off-by: Jeremiah McConnell <miah@miah.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 72d61478..8f6e9768 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -984,7 +984,7 @@ AC_DEFINE_UNQUOTED(AVAHI_AUTOIPD_GROUP,"$AVAHI_AUTOIPD_GROUP", [Group for runnin
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -24638,7 +24638,7 @@ _ACEOF
|
||||
#
|
||||
# Avahi runtime dir
|
||||
#
|
||||
-avahi_runtime_dir="/run"
|
||||
+avahi_runtime_dir="${localstatedir}/run"
|
||||
avahi_socket="${avahi_runtime_dir}/avahi-daemon/socket"
|
||||
AC_SUBST(avahi_runtime_dir)
|
||||
AC_SUBST(avahi_socket)
|
||||
|
||||
|
||||
|
|
Loading…
Reference in a new issue