grilo: update to 0.3.10 and build with meson
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
c59f56e8ac
commit
1437cbb5e8
2 changed files with 11 additions and 30 deletions
|
@ -6,8 +6,8 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=grilo
|
||||
PKG_VERSION:=0.3.6
|
||||
PKG_RELEASE:=4
|
||||
PKG_VERSION:=0.3.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
||||
|
||||
|
@ -16,14 +16,15 @@ PKG_LICENSE_FILES:=COPYING
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNOME/grilo/0.3/
|
||||
PKG_HASH:=1e65ca82dd58020451417fde79310d4b940adc3f63ab59997419c52ed3bc9c91
|
||||
PKG_HASH:=7e44b2e74c31ed24eb97e43265a9e41effe8660287b02295111805c7bda7f1e8
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=vala/host
|
||||
PKG_BUILD_DEPENDS:=meson/host vala/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
include ../../devel/meson/meson.mk
|
||||
|
||||
define Package/grilo
|
||||
SECTION:=multimedia
|
||||
|
@ -38,13 +39,12 @@ define Package/grilo/decription
|
|||
multimedia content, using a pluggable system.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-compile-warnings \
|
||||
--disable-debug \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-introspection \
|
||||
--disable-test-ui \
|
||||
--disable-vala
|
||||
MESON_ARGS += \
|
||||
-Denable-grl-pls=false \
|
||||
-Denable-gtk-doc=false \
|
||||
-Denable-introspection=false \
|
||||
-Denable-test-ui=false \
|
||||
-Denable-vala=false \
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include/
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -14433,16 +14433,6 @@ else
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $IT_PERL_VERSION" >&5
|
||||
$as_echo "$IT_PERL_VERSION" >&6; }
|
||||
fi
|
||||
-if test "x" != "xno-xml"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for XML::Parser" >&5
|
||||
-$as_echo_n "checking for XML::Parser... " >&6; }
|
||||
- if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: ok" >&5
|
||||
-$as_echo "ok" >&6; }
|
||||
- else
|
||||
- as_fn_error $? "XML::Parser perl module is required for intltool" "$LINENO" 5
|
||||
- fi
|
||||
-fi
|
||||
|
||||
# Substitute ALL_LINGUAS so we can use it in po/Makefile
|
||||
|
Loading…
Reference in a new issue