apr-util: add drivers
This adds the following drivers as extra packages: - openssl - mysql - odbc - pgsql - sqlite3 - gdbm (dbm) - ldap This also removes the gratuitous dependency on libsqlite3 from libaprutil (dbd_sqlite3 was nevery packaged before, after all). With this ldap and session-crypto support can be enabled in apache. The mysql driver is currently marked BROKEN, because apr-util still uses mysql server headers, which aren't part of mariadb-connector-c. But there's work underway at apr-util upstream to fix that so that BROKEN can be removed during a feature version bump. The gdbm dbm driver got added together with a patch that fixes the error handling. Patch is from Debian. Resolves #10886 Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
This commit is contained in:
parent
03124bf4b4
commit
141bd55316
2 changed files with 173 additions and 8 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=apr-util
|
||||
PKG_VERSION:=1.6.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@APACHE/apr/
|
||||
|
@ -20,6 +20,15 @@ PKG_CPE_ID:=cpe:/a:apache:apr-util
|
|||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_CONFIG_DEPENDS := \
|
||||
CONFIG_PACKAGE_libaprutil-crypto-openssl \
|
||||
CONFIG_PACKAGE_libaprutil-dbd-mysql \
|
||||
CONFIG_PACKAGE_libaprutil-dbd-odbc \
|
||||
CONFIG_PACKAGE_libaprutil-dbd-pgsql \
|
||||
CONFIG_PACKAGE_libaprutil-dbd-sqlite3 \
|
||||
CONFIG_PACKAGE_libaprutil-dbm-gdbm \
|
||||
CONFIG_PACKAGE_libaprutil-ldap
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
@ -27,33 +36,103 @@ PKG_INSTALL:=1
|
|||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/nls.mk
|
||||
|
||||
define Package/libaprutil
|
||||
define Package/libaprutil/Default
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libapr +libexpat +libsqlite3 +libuuid $(ICONV_DEPENDS)
|
||||
TITLE:=Apache Portable Runtime Utility Library
|
||||
URL:=http://apr.apache.org/
|
||||
endef
|
||||
|
||||
define Package/libaprutil
|
||||
$(call Package/libaprutil/Default)
|
||||
DEPENDS:=+libapr +libexpat +libuuid $(ICONV_DEPENDS)
|
||||
TITLE:=Apache Portable Runtime Utility Library
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-pgsql=no \
|
||||
--with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
|
||||
--with-expat="$(STAGING_DIR)/usr" \
|
||||
--with-iconv="$(ICONV_PREFIX)" \
|
||||
--without-sqlite2 \
|
||||
--with-sqlite3="$(STAGING_DIR)/usr"
|
||||
--without-sqlite2
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-crypto-openssl),)
|
||||
CONFIGURE_ARGS += --with-crypto --with-openssl="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS += --without-crypto
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-dbd-mysql),)
|
||||
CONFIGURE_ARGS += --with-mysql="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS += --without-mysql
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-dbd-odbc),)
|
||||
CONFIGURE_ARGS += --with-odbc="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS += --without-odbc
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-dbd-pgsql),)
|
||||
CONFIGURE_ARGS += --with-pgsql="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS += --without-pgsql
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-dbd-sqlite3),)
|
||||
CONFIGURE_ARGS += --with-sqlite3="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS += --without-sqlite3
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-dbm-gdbm),)
|
||||
CONFIGURE_ARGS += --with-gdbm="$(STAGING_DIR)/usr"
|
||||
else
|
||||
CONFIGURE_ARGS += --without-gdbm
|
||||
endif
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-ldap),)
|
||||
CONFIGURE_ARGS += \
|
||||
--with-ldap \
|
||||
--with-ldap-include="$(STAGING_DIR)/usr/include" \
|
||||
--with-ldap-lib="$(STAGING_DIR)/usr/lib"
|
||||
else
|
||||
CONFIGURE_ARGS += \
|
||||
--without-ldap
|
||||
endif
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_file_dbd_apr_dbd_mysql_c=no \
|
||||
ac_cv_path_ODBC_CONFIG= \
|
||||
APR_BUILD_DIR="$(STAGING_DIR)/usr/share/build-1"
|
||||
|
||||
define Package/libaprutil/install/driver
|
||||
$(INSTALL_DIR) $(1)/usr/lib/apr-util-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_$(2)*.so \
|
||||
$(1)/usr/lib/apr-util-1
|
||||
endef
|
||||
|
||||
define Package/libaprutil/Driver
|
||||
define Package/libaprutil-$(subst _,-,$(1))
|
||||
$(call Package/libaprutil/Default)
|
||||
TITLE:=libaprutil - $(2) driver
|
||||
DEPENDS:=libaprutil $(patsubst +%,+PACKAGE_libaprutil-$(subst _,-,$(1)):%,$(3))
|
||||
endef
|
||||
define Package/libaprutil-$(subst _,-,$(1))/install
|
||||
$(foreach d,$(1),$(call Package/libaprutil/install/driver,$$(1),$(d));)
|
||||
endef
|
||||
$$(eval $$(call BuildPackage,libaprutil-$(subst _,-,$(1))))
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1/ $(1)/usr/lib $(1)/usr/lib/pkgconfig/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config \
|
||||
$(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
|
||||
$(1)/usr/include/apr-1/
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-crypto-openssl)$(CONFIG_PACKAGE_libaprutil-dbd-pgsql)$(CONFIG_PACKAGE_libaprutil-dbd-sqlite3)$(CONFIG_PACKAGE_libaprutil-ldap),)
|
||||
$(INSTALL_DIR) $(1)/usr/lib/apr-util-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_*{la,a,so*} \
|
||||
$(1)/usr/lib/apr-util-1
|
||||
endif
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
|
||||
$(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
|
||||
|
@ -71,3 +150,10 @@ define Package/libaprutil/install
|
|||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libaprutil))
|
||||
$(eval $(call Package/libaprutil/Driver,crypto_openssl,OpenSSL,+libopenssl))
|
||||
$(eval $(call Package/libaprutil/Driver,dbd_mysql,MySQL,+libmariadb @BROKEN))
|
||||
$(eval $(call Package/libaprutil/Driver,dbd_odbc,ODBC,+unixodbc))
|
||||
$(eval $(call Package/libaprutil/Driver,dbd_pgsql,PostgreSQL,+libpq))
|
||||
$(eval $(call Package/libaprutil/Driver,dbd_sqlite3,SQLite3,+libsqlite3))
|
||||
$(eval $(call Package/libaprutil/Driver,dbm_gdbm,GDBM dbm,+libgdbm))
|
||||
$(eval $(call Package/libaprutil/Driver,ldap,LDAP,+libopenldap))
|
||||
|
|
79
libs/apr-util/patches/002-fix-gdbm-error-handling.patch
Normal file
79
libs/apr-util/patches/002-fix-gdbm-error-handling.patch
Normal file
|
@ -0,0 +1,79 @@
|
|||
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=889170
|
||||
# needs to be submitted upstream
|
||||
--- apr-util.orig/dbm/apr_dbm_gdbm.c
|
||||
+++ apr-util/dbm/apr_dbm_gdbm.c
|
||||
@@ -36,13 +36,22 @@
|
||||
static apr_status_t g2s(int gerr)
|
||||
{
|
||||
if (gerr == -1) {
|
||||
- /* ### need to fix this */
|
||||
- return APR_EGENERAL;
|
||||
+ return APR_OS_START_USEERR + gdbm_errno;
|
||||
}
|
||||
|
||||
return APR_SUCCESS;
|
||||
}
|
||||
|
||||
+static apr_status_t gdat2s(datum d)
|
||||
+{
|
||||
+ if (d.dptr == NULL) {
|
||||
+ return APR_OS_START_USEERR + gdbm_errno;
|
||||
+ }
|
||||
+
|
||||
+ return APR_SUCCESS;
|
||||
+}
|
||||
+
|
||||
+
|
||||
static apr_status_t datum_cleanup(void *dptr)
|
||||
{
|
||||
if (dptr)
|
||||
@@ -55,19 +64,15 @@ static apr_status_t set_error(apr_dbm_t
|
||||
{
|
||||
apr_status_t rv = APR_SUCCESS;
|
||||
|
||||
- /* ### ignore whatever the DBM said (dbm_said); ask it explicitly */
|
||||
-
|
||||
- if ((dbm->errcode = gdbm_errno) == GDBM_NO_ERROR) {
|
||||
+ if (dbm_said == APR_SUCCESS) {
|
||||
+ dbm->errcode = GDBM_NO_ERROR;
|
||||
dbm->errmsg = NULL;
|
||||
}
|
||||
else {
|
||||
+ dbm->errcode = dbm_said;
|
||||
dbm->errmsg = gdbm_strerror(gdbm_errno);
|
||||
- rv = APR_EGENERAL; /* ### need something better */
|
||||
}
|
||||
|
||||
- /* captured it. clear it now. */
|
||||
- gdbm_errno = GDBM_NO_ERROR;
|
||||
-
|
||||
return rv;
|
||||
}
|
||||
|
||||
@@ -144,7 +149,7 @@ static apr_status_t vt_gdbm_fetch(apr_db
|
||||
|
||||
/* store the error info into DBM, and return a status code. Also, note
|
||||
that *pvalue should have been cleared on error. */
|
||||
- return set_error(dbm, APR_SUCCESS);
|
||||
+ return set_error(dbm, gdat2s(rd));
|
||||
}
|
||||
|
||||
static apr_status_t vt_gdbm_store(apr_dbm_t *dbm, apr_datum_t key,
|
||||
@@ -203,7 +208,7 @@ static apr_status_t vt_gdbm_firstkey(apr
|
||||
apr_pool_cleanup_null);
|
||||
|
||||
/* store any error info into DBM, and return a status code. */
|
||||
- return set_error(dbm, APR_SUCCESS);
|
||||
+ return set_error(dbm, gdat2s(rd));
|
||||
}
|
||||
|
||||
static apr_status_t vt_gdbm_nextkey(apr_dbm_t *dbm, apr_datum_t *pkey)
|
||||
@@ -223,7 +228,7 @@ static apr_status_t vt_gdbm_nextkey(apr_
|
||||
apr_pool_cleanup_null);
|
||||
|
||||
/* store any error info into DBM, and return a status code. */
|
||||
- return set_error(dbm, APR_SUCCESS);
|
||||
+ return set_error(dbm, gdat2s(rd));
|
||||
}
|
||||
|
||||
static void vt_gdbm_freedatum(apr_dbm_t *dbm, apr_datum_t data)
|
Loading…
Reference in a new issue