frr: fix running on mips (again)
add mips fix missed on version upgrade Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
This commit is contained in:
parent
7479b3ecfa
commit
13c83f11e5
2 changed files with 15 additions and 1 deletions
|
@ -8,7 +8,7 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
PKG_NAME:=frr
|
PKG_NAME:=frr
|
||||||
PKG_VERSION:=7.4
|
PKG_VERSION:=7.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE_URL:=https://github.com/FRRouting/frr/archive/
|
PKG_SOURCE_URL:=https://github.com/FRRouting/frr/archive/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
14
net/frr/patches/098-fix_mips_libyang.patch
Normal file
14
net/frr/patches/098-fix_mips_libyang.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
--- a/lib/northbound.h
|
||||||
|
+++ b/lib/northbound.h
|
||||||
|
@@ -504,11 +504,7 @@ struct frr_yang_module_info {
|
||||||
|
|
||||||
|
/* Priority - lower priorities are processed first. */
|
||||||
|
uint32_t priority;
|
||||||
|
-#if defined(__GNUC__) && ((__GNUC__ - 0) < 5) && !defined(__clang__)
|
||||||
|
} nodes[YANG_MODULE_MAX_NODES + 1];
|
||||||
|
-#else
|
||||||
|
- } nodes[];
|
||||||
|
-#endif
|
||||||
|
};
|
||||||
|
|
||||||
|
/* Northbound error codes. */
|
Loading…
Reference in a new issue