From 13af207aaa89a6241435b9b6d8ee17890d5870ee Mon Sep 17 00:00:00 2001
From: "W. Michael Petullo" <mike@flyn.org>
Date: Tue, 30 Sep 2014 22:54:05 -0400
Subject: [PATCH] dovecot: add LDAP option

Signed-off-by: W. Michael Petullo <mike@flyn.org>
---
 mail/dovecot/Makefile | 21 ++++++++++++++++++++-
 1 file changed, 20 insertions(+), 1 deletion(-)

diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 1f6becff7..da1f1d41f 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libopenssl +librt +zlib +libbz2 +libcap
+  DEPENDS:=+DOVECOT_LDAP:libopenldap +libopenssl +librt +zlib +libbz2 +libcap
   TITLE:=An IMAP and POP3 daemon
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
   URL:=http://www.dovecot.org/
@@ -37,6 +37,17 @@ define Package/dovecot/description
  Dovecot is a program which provides POP3 and IMAP services.
 endef
 
+define Package/dovecot/config
+        menu "Select dovecot build options"
+                depends on PACKAGE_dovecot
+                config DOVECOT_LDAP
+                        bool "LDAP support"
+                        default y
+                        help
+                          Implements LDAP support in dovecot.
+        endmenu
+endef
+
 CONFIGURE_ARGS += \
 	--without-gssapi \
 	--without-pam \
@@ -45,6 +56,14 @@ CONFIGURE_ARGS += \
 	--without-lzma \
 	--without-lz4
 
+ifneq ($(strip $(CONFIG_DOVECOT_LDAP)),)
+  CONFIGURE_ARGS+= \
+	--with-ldap=yes
+else
+  CONFIGURE_ARGS+= \
+	--with-ldap=no
+endif
+
 CONFIGURE_VARS += \
 	RPCGEN= \
 	i_cv_signed_size_t=no \