conmon: update to 2.1.5
Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
This commit is contained in:
parent
ad0aa1b2fc
commit
1394035a39
2 changed files with 6 additions and 21 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=conmon
|
||||
PKG_VERSION:=2.1.0
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
PKG_VERSION:=2.1.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/containers/$(PKG_NAME)/archive/v$(PKG_VERSION)
|
||||
PKG_HASH:=874909d831feac75e452562087f6ea0eb39848ef144397bdd8f0daf579c5ee85
|
||||
PKG_HASH:=ee3179ee2b9a9107acec00eb546062cf7deb847f135a3b81503d22b0d226b3ed
|
||||
|
||||
PKG_MAINTAINER:=Oskari Rauta <oskari.rauta@gmail.com>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
|
|
@ -1,26 +1,11 @@
|
|||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -35,14 +35,6 @@ add_project_arguments('-Os', '-Wall', '-
|
||||
|
||||
glib = dependency('glib-2.0')
|
||||
|
||||
-cc = meson.get_compiler('c')
|
||||
-null_dep = dependency('', required : false)
|
||||
-if cc.has_function('dlopen')
|
||||
- libdl = null_dep
|
||||
-else
|
||||
- libdl = cc.find_library('dl')
|
||||
-endif
|
||||
-
|
||||
executable('conmon',
|
||||
['src/conmon.c',
|
||||
'src/config.h',
|
||||
@@ -78,7 +70,7 @@ executable('conmon',
|
||||
@@ -90,7 +90,7 @@ executable('conmon',
|
||||
'src/utils.h',
|
||||
'src/seccomp_notify.c',
|
||||
'src/seccomp_notify.h'],
|
||||
- dependencies : [glib, libdl],
|
||||
+ dependencies : [glib],
|
||||
- dependencies : [glib, libdl, sd_journal, seccomp],
|
||||
+ dependencies : [glib, sd_journal, seccomp],
|
||||
install : true,
|
||||
install_dir : join_paths(get_option('libexecdir'), 'podman'),
|
||||
)
|
||||
|
|
Loading…
Reference in a new issue