Merge pull request #7846 from neheb/ipsec
ipsec-tools: Fix compilation without deprecated OpenSSL 1.0.2 APIs
This commit is contained in:
commit
13199f6ea1
2 changed files with 22 additions and 1 deletions
|
@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=ipsec-tools
|
||||
PKG_VERSION:=0.8.2
|
||||
PKG_RELEASE:=8
|
||||
PKG_RELEASE:=9
|
||||
PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>, \
|
||||
Vitaly Protsko <villy@sft.ru>
|
||||
PKG_LICENSE := BSD-3-Clause
|
||||
|
|
21
net/ipsec-tools/patches/020-openssl-deprecated.patch
Normal file
21
net/ipsec-tools/patches/020-openssl-deprecated.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- a/src/racoon/crypto_openssl.c
|
||||
+++ b/src/racoon/crypto_openssl.c
|
||||
@@ -1087,7 +1087,7 @@ eay_strerror()
|
||||
int line, flags;
|
||||
unsigned long es;
|
||||
|
||||
-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
es = 0; /* even when allowed by OPENSSL_API_COMPAT, it is defined as 0 */
|
||||
#else
|
||||
es = CRYPTO_thread_id();
|
||||
--- a/src/racoon/openssl_compat.h
|
||||
+++ b/src/racoon/openssl_compat.h
|
||||
@@ -5,6 +5,7 @@
|
||||
#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
|
||||
#include <openssl/rsa.h>
|
||||
+#include <openssl/bn.h>
|
||||
#include <openssl/dh.h>
|
||||
#include <openssl/evp.h>
|
||||
#include <openssl/hmac.h>
|
Loading…
Reference in a new issue