From 12646b51ebf95d6c5fadf711cd1e2143f35b8b24 Mon Sep 17 00:00:00 2001
From: Daniel Engberg <daniel.engberg.lists@pyret.net>
Date: Sun, 23 Jul 2017 23:17:13 +0200
Subject: [PATCH] libs/expat: Fix poor entropy compilation error

Add the same workaround as for the expat package in toolchain.
I'm not really sure what made it work for me earlier but this seems to fix it.

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
---
 libs/expat/Makefile | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/libs/expat/Makefile b/libs/expat/Makefile
index 5819e0f4f..894d0789c 100644
--- a/libs/expat/Makefile
+++ b/libs/expat/Makefile
@@ -39,6 +39,9 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
+HOST_CONFIGURE_VARS += \
+	CPPFLAGS="$(HOST_CFLAGS) -DXML_POOR_ENTROPY"
+
 CONFIGURE_ARGS += \
 	--enable-shared \
 	--enable-static