flac: Fix musl x86 build (__sigemptyset undefined)
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
46432e174b
commit
1263599f96
2 changed files with 13 additions and 2 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2015 OpenWrt.org
|
||||
# Copyright (C) 2006-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=flac
|
||||
PKG_VERSION:=1.3.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/flac/
|
||||
|
|
11
libs/flac/patches/020-fix-musl-sigemptyset-x86.patch
Normal file
11
libs/flac/patches/020-fix-musl-sigemptyset-x86.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/libFLAC/cpu.c
|
||||
+++ b/src/libFLAC/cpu.c
|
||||
@@ -243,7 +243,7 @@ void FLAC__cpu_info(FLAC__CPUInfo *info)
|
||||
struct sigaction sigill_save;
|
||||
struct sigaction sigill_sse;
|
||||
sigill_sse.sa_sigaction = sigill_handler_sse_os;
|
||||
- __sigemptyset(&sigill_sse.sa_mask);
|
||||
+ sigemptyset(&sigill_sse.sa_mask);
|
||||
sigill_sse.sa_flags = SA_SIGINFO | SA_RESETHAND; /* SA_RESETHAND just in case our SIGILL return jump breaks, so we don't get stuck in a loop */
|
||||
if(0 == sigaction(SIGILL, &sigill_sse, &sigill_save))
|
||||
{
|
Loading…
Reference in a new issue