Merge pull request #17154 from jefferyto/python-pycparser-2.21
python-pycparser: Update to 2.21, update patch
This commit is contained in:
commit
122ee76623
3 changed files with 11 additions and 11 deletions
|
@ -1,2 +1,2 @@
|
|||
cffi==1.15.0 --hash=sha256:920f0d66a896c2d99f0adbb391f990a84091179542c205fa53ce5787aff87954
|
||||
pycparser==2.20 --hash=sha256:2d475327684562c3a96cc71adf7dc8c4f0565175cf86b6d7a404ff4c771f15f0
|
||||
pycparser==2.21 --hash=sha256:e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206
|
||||
|
|
|
@ -8,11 +8,11 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-pycparser
|
||||
PKG_VERSION:=2.20
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=2.21
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=pycparser
|
||||
PKG_HASH:=2d475327684562c3a96cc71adf7dc8c4f0565175cf86b6d7a404ff4c771f15f0
|
||||
PKG_HASH:=e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/pycparser/c_lexer.py
|
||||
+++ b/pycparser/c_lexer.py
|
||||
@@ -9,8 +9,8 @@
|
||||
@@ -8,8 +8,8 @@
|
||||
#------------------------------------------------------------------------------
|
||||
import re
|
||||
import sys
|
||||
|
||||
-from .ply import lex
|
||||
-from .ply.lex import TOKEN
|
||||
|
@ -13,10 +13,10 @@
|
|||
class CLexer(object):
|
||||
--- a/pycparser/c_parser.py
|
||||
+++ b/pycparser/c_parser.py
|
||||
@@ -8,7 +8,7 @@
|
||||
@@ -6,7 +6,7 @@
|
||||
# Eli Bendersky [https://eli.thegreenplace.net/]
|
||||
# License: BSD
|
||||
#------------------------------------------------------------------------------
|
||||
import re
|
||||
|
||||
-from .ply import yacc
|
||||
+from ply import yacc
|
||||
|
||||
|
@ -24,8 +24,8 @@
|
|||
from .c_lexer import CLexer
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -60,7 +60,7 @@ setup(
|
||||
'Programming Language :: Python :: 3.6',
|
||||
@@ -64,7 +64,7 @@ setup(
|
||||
'Programming Language :: Python :: 3.10',
|
||||
],
|
||||
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
|
||||
- packages=['pycparser', 'pycparser.ply'],
|
||||
|
|
Loading…
Reference in a new issue