diff --git a/net/cifs-utils/Makefile b/net/cifs-utils/Makefile
index 0c3d84c30..03f5acac5 100644
--- a/net/cifs-utils/Makefile
+++ b/net/cifs-utils/Makefile
@@ -8,18 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cifs-utils
-PKG_VERSION:=6.9
-PKG_RELEASE:=2
+PKG_VERSION:=6.10
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.samba.org/pub/linux-cifs/cifs-utils/
-PKG_HASH:=18d8f1bf92c13c4d611502dbd6759e3a766ddc8467ec8a2eda3f589e40b9ac9c
+PKG_HASH:=92fc29c8e9039637f3344267500f1fa381e2cccd7d10142f0c1676fa575904a7
 
 PKG_MAINTAINER:=
-PKG_LICENSE:=GPL-3.0
+PKG_LICENSE:=GPL-3.0-or-later
 PKG_LICENSE_FILES:=COPYING
 PKG_CPE_ID:=cpe:/a:debian:cifs-utils
 
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
@@ -64,6 +65,7 @@ endef
 define Package/cifsmount/install
 	$(INSTALL_DIR) $(1)/usr/sbin
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/mount.cifs $(1)/usr/sbin/
+	$(LN) /usr/sbin/mount.cifs $(1)/usr/sbin/mount.smb3
 endef
 
 define Package/smbinfo/install
diff --git a/net/cifs-utils/patches/010-no-libtalloc.patch b/net/cifs-utils/patches/010-no-libtalloc.patch
index 859a5c539..29de8f138 100644
--- a/net/cifs-utils/patches/010-no-libtalloc.patch
+++ b/net/cifs-utils/patches/010-no-libtalloc.patch
@@ -1,5 +1,3 @@
-diff --git a/data_blob.h b/data_blob.h
-index 3d96147..c20749d 100644
 --- a/data_blob.h
 +++ b/data_blob.h
 @@ -23,7 +23,7 @@
diff --git a/net/cifs-utils/patches/020-no-smb3.patch b/net/cifs-utils/patches/020-no-smb3.patch
new file mode 100644
index 000000000..bb20af422
--- /dev/null
+++ b/net/cifs-utils/patches/020-no-smb3.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -119,10 +119,8 @@ endif
+ SUBDIRS = contrib
+ 
+ install-exec-hook:
+-	(cd $(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
+ 
+ install-data-hook:
+-	(cd $(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
+ 
+ uninstall-hook:
+ 	(cd $(ROOTSBINDIR) && rm -f $(ROOTSBINDIR)/mount.smb3)