Merge pull request #6101 from cotequeiroz/libshout_openssl-1.1

libshout: add openssl 1.1.0 compatibility
This commit is contained in:
Ted Hess 2018-05-24 10:56:12 +00:00 committed by GitHub
commit 11e87d3ba9
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 16 additions and 1 deletions

View file

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libshout
PKG_VERSION:=2.4.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View file

@ -0,0 +1,15 @@
--- a/src/tls.c
+++ b/src/tls.c
@@ -63,10 +63,12 @@ static inline int tls_setup(shout_tls_t
{
SSL_METHOD *meth;
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
SSL_library_init();
SSL_load_error_strings();
SSLeay_add_all_algorithms();
SSLeay_add_ssl_algorithms();
+#endif
meth = TLSv1_client_method();
if (!meth)