parent
8a878440bf
commit
11a79e9aa2
2 changed files with 4 additions and 6 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=postfix
|
PKG_NAME:=postfix
|
||||||
PKG_VERSION:=3.5.8
|
PKG_VERSION:=3.5.8
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
|
|
|
@ -5,17 +5,15 @@
|
||||||
case $# in
|
case $# in
|
||||||
# Officially supported usage.
|
# Officially supported usage.
|
||||||
- 0) SYSTEM=`(uname -s) 2>/dev/null`
|
- 0) SYSTEM=`(uname -s) 2>/dev/null`
|
||||||
+ 0) SYSTEM="OpenWrt"
|
+ 0) SYSTEM="OpenWRT"
|
||||||
RELEASE=`(uname -r) 2>/dev/null`
|
RELEASE=`(uname -r) 2>/dev/null`
|
||||||
# No ${x%%y} support in Solaris 11 /bin/sh
|
# No ${x%%y} support in Solaris 11 /bin/sh
|
||||||
RELEASE_MAJOR=`expr "$RELEASE" : '\([0-9]*\)'` || exit 1
|
RELEASE_MAJOR=`expr "$RELEASE" : '\([0-9]*\)'` || exit 1
|
||||||
@@ -242,6 +242,17 @@ case "$SYSTEM" in
|
@@ -242,6 +242,15 @@ case "$SYSTEM" in
|
||||||
esac
|
esac
|
||||||
|
|
||||||
case "$SYSTEM.$RELEASE" in
|
case "$SYSTEM.$RELEASE" in
|
||||||
+ OpenWrt*) SYSTYPE=LINUX5
|
+ OpenWRT*) SYSTYPE=LINUX$RELEASE_MAJOR
|
||||||
+ AR="${CC-gcc}-ar"
|
|
||||||
+ RANLIB="${CC-gcc}-ranlib"
|
|
||||||
+ SYSLIBS="$SYSLIBS -ldl"
|
+ SYSLIBS="$SYSLIBS -ldl"
|
||||||
+ : ${SHLIB_SUFFIX=.so}
|
+ : ${SHLIB_SUFFIX=.so}
|
||||||
+ : ${SHLIB_CFLAGS=-fPIC}
|
+ : ${SHLIB_CFLAGS=-fPIC}
|
||||||
|
|
Loading…
Reference in a new issue