dbus: Update to 1.12.8
Update dbus to 1.12.8 Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
48d5f1a591
commit
113a34788d
3 changed files with 62 additions and 117 deletions
|
@ -7,27 +7,22 @@
|
|||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
# Make sure to also update the dbus-x package
|
||||
PKG_NAME:=dbus
|
||||
PKG_VERSION:=1.10.4
|
||||
PKG_VERSION:=1.12.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
|
||||
PKG_HASH:=ad7dcad73ad9b0ff55819985d354eacfffe07e2eb8c763e155efc21d6001084b
|
||||
PKG_SOURCE_URL:=https://dbus.freedesktop.org/releases/dbus/
|
||||
PKG_HASH:=e2dc99e7338303393b6663a98320aba6a63421bcdaaf571c8022f815e5896eb3
|
||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||
PKG_LICENSE:=AFL-2.1
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
TARGET_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
|
||||
define Package/dbus/Default
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
|
@ -69,7 +64,7 @@ endef
|
|||
define Package/dbus-utils
|
||||
$(call Package/dbus/Default)
|
||||
TITLE+= (utilities)
|
||||
DEPENDS:= dbus
|
||||
DEPENDS:= +dbus
|
||||
endef
|
||||
|
||||
define Package/dbus-utils/Description
|
||||
|
@ -77,135 +72,98 @@ $(call Package/dbus/Default/description)
|
|||
This package contains D-Bus utilities.
|
||||
endef
|
||||
|
||||
|
||||
define Build/Prepare
|
||||
$(Build/Prepare/Default)
|
||||
$(SED) 's/-Wl,--gc-sections/--gc-sections/' $(PKG_BUILD_DIR)/configure
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-maintainer-mode \
|
||||
--disable-developer \
|
||||
--enable-debug=no \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-abstract-sockets \
|
||||
--disable-ansi \
|
||||
--disable-asserts \
|
||||
--disable-console-owner-file \
|
||||
--disable-doxygen-docs \
|
||||
--disable-compiler_coverage \
|
||||
--disable-selinux \
|
||||
--disable-tests \
|
||||
--disable-static \
|
||||
--disable-verbose-mode \
|
||||
--disable-asserts \
|
||||
--disable-xml-docs \
|
||||
--with-xml="expat" \
|
||||
--disable-doxygen-docs \
|
||||
--disable-ducktype-docs \
|
||||
--disable-selinux \
|
||||
--disable-apparmor \
|
||||
--disable-libaudit \
|
||||
--enable-inotify \
|
||||
--disable-kqueue \
|
||||
--disable-console-owner-file \
|
||||
--disable-systemd \
|
||||
--disable-tests \
|
||||
--disable-code-coverage \
|
||||
--disable-x11-autolaunch \
|
||||
--with-session-socket-dir=/tmp \
|
||||
--with-system-socket=/var/run/dbus/system_bus_socket \
|
||||
--with-system-pid-file=/var/run/dbus.pid \
|
||||
--with-dbus-user=root \
|
||||
--with-dbus-daemondir="/usr/sbin" \
|
||||
--with-system-socket="/var/run/dbus/system_bus_socket" \
|
||||
--with-system-pid-file="/var/run/dbus.pid" \
|
||||
--without-x \
|
||||
--libexecdir=/usr/lib/dbus-1
|
||||
|
||||
CONFIGURE_VARS+= \
|
||||
ac_cv_have_abstract_sockets="yes" \
|
||||
ac_cv_lib_expat_XML_ParserCreate_MM="yes" \
|
||||
--without-x
|
||||
|
||||
HOST_CONFIGURE_ARGS+= \
|
||||
--disable-maintainer-mode \
|
||||
--disable-developer \
|
||||
--enable-debug=no \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-abstract-sockets \
|
||||
--disable-ansi \
|
||||
--disable-asserts \
|
||||
--disable-console-owner-file \
|
||||
--disable-docygen-docs \
|
||||
--disable-compiler_coverage \
|
||||
--disable-selinux \
|
||||
--disable-tests \
|
||||
--disable-static \
|
||||
--disable-verbose-mode \
|
||||
--disable-asserts \
|
||||
--disable-xml-docs \
|
||||
--with-dbus-user=root \
|
||||
--with-dbus-daemondir="$(STAGING_DIR_HOSTPKG)/bin" \
|
||||
--disable-doxygen-docs \
|
||||
--disable-ducktype-docs \
|
||||
--disable-selinux \
|
||||
--disable-apparmor \
|
||||
--disable-libaudit \
|
||||
--enable-inotify \
|
||||
--disable-kqueue \
|
||||
--disable-console-owner-file \
|
||||
--disable-systemd \
|
||||
--disable-tests \
|
||||
--disable-code-coverage \
|
||||
--disable-x11-autolaunch \
|
||||
--with-system-socket="$(STAGING_DIR_HOSTPKG)/var/run/dbus/system_bus_socket" \
|
||||
--with-system-pid-file="$(STAGING_DIR_HOSTPKG)/var/run/dbus.pid" \
|
||||
--without-x \
|
||||
--libexecdir="$(STAGING_DIR_HOSTPKG)/lib/dbus-1"
|
||||
|
||||
HOST_CONFIGURE_VARS+= \
|
||||
ac_cv_have_abstract_sockets="yes" \
|
||||
ac_cv_lib_expat_XML_ParserCreate_MM="yes" \
|
||||
--with-dbus-daemondir="$(STAGING_DIR_HOSTPKG)/bin" \
|
||||
--without-x
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/dbus-1.0 \
|
||||
$(1)/usr/include/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/dbus-1.0 $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/dbus-1.0/include/dbus/
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/dbus-1.0/include/dbus/*.h \
|
||||
$(1)/usr/lib/dbus-1.0/include/dbus/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libdbus-1.{so*,la,a} \
|
||||
$(1)/usr/lib/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/dbus-1.0 \
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libdbus-1.{so*,la} \
|
||||
$(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dbus-1.0 $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/dbus-1.pc \
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/dbus-1.pc \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/dbus/conffiles
|
||||
/etc/dbus-1/session.conf
|
||||
/etc/dbus-1/system.conf
|
||||
endef
|
||||
|
||||
define Package/libdbus/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libdbus-1.so.* \
|
||||
$(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdbus-1.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/dbus/install
|
||||
$(INSTALL_DIR) $(1)/usr/share
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/share/dbus-1 \
|
||||
$(1)/usr/share/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/dbus-1
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/dbus-1/dbus-daemon-launch-helper \
|
||||
$(1)/usr/lib/dbus-1/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/sbin/dbus-daemon \
|
||||
$(1)/usr/sbin/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/dbus-uuidgen \
|
||||
$(1)/usr/bin/
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/dbus-launch \
|
||||
$(1)/usr/bin/dbus-launch.real
|
||||
$(INSTALL_BIN) \
|
||||
./files/dbus-launch \
|
||||
$(1)/usr/bin/
|
||||
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-cleanup-sockets $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-daemon $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-launch $(1)/usr/bin/dbus-launch.real
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-uuidgen $(1)/usr/bin/
|
||||
$(INSTALL_BIN) ./files/dbus-launch $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/dbus-daemon-launch-helper $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) \
|
||||
./files/dbus.init \
|
||||
$(1)/etc/init.d/dbus
|
||||
$(INSTALL_BIN) ./files/dbus.init $(1)/etc/init.d/dbus
|
||||
$(INSTALL_DIR) $(1)/usr/share/dbus-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/dbus-1 $(1)/usr/share/
|
||||
endef
|
||||
|
||||
define Package/dbus-utils/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/dbus-{send,monitor,cleanup-sockets} \
|
||||
$(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dbus-{monitor,send,update-activation-environment} $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
||||
|
|
|
@ -9,9 +9,9 @@ start() {
|
|||
mkdir -m 0755 -p /var/lib/dbus
|
||||
mkdir -m 0755 -p /var/run/dbus
|
||||
[ -x /usr/bin/dbus-uuidgen ] && /usr/bin/dbus-uuidgen --ensure
|
||||
service_start /usr/sbin/dbus-daemon --system
|
||||
service_start /usr/bin/dbus-daemon --system
|
||||
}
|
||||
|
||||
stop() {
|
||||
service_stop /usr/sbin/dbus-daemon && rm $SERVICE_PID_FILE
|
||||
service_stop /usr/bin/dbus-daemon
|
||||
}
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
Index: dbus-1.9.4/tools/tool-common.c
|
||||
===================================================================
|
||||
--- dbus-1.9.4.orig/tools/tool-common.c
|
||||
+++ dbus-1.9.4/tools/tool-common.c
|
||||
@@ -29,6 +29,8 @@
|
||||
#include <string.h>
|
||||
#include <time.h>
|
||||
|
||||
+#include <sys/select.h>
|
||||
+
|
||||
#ifdef DBUS_WIN
|
||||
#include <windows.h>
|
||||
#endif
|
Loading…
Reference in a new issue