strongswan: bump to 5.5.0 (#2976)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
This commit is contained in:
parent
c130f17657
commit
1138d6fee0
4 changed files with 16 additions and 15 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=strongswan
|
||||
PKG_VERSION:=5.4.0
|
||||
PKG_VERSION:=5.5.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://download.strongswan.org/ http://download2.strongswan.org/
|
||||
PKG_MD5SUM:=9d7c77b0da9b69f859624897e5e9ebbf
|
||||
PKG_MD5SUM:=a96fa7eb6c62b40143dadb064b6bd586
|
||||
PKG_LICENSE:=GPL-2.0+
|
||||
PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
|
||||
|
||||
|
@ -382,7 +382,8 @@ CONFIGURE_ARGS+= \
|
|||
--with-routing-table-prio="$(call qstrip,$(CONFIG_STRONGSWAN_ROUTING_TABLE_PRIO))" \
|
||||
$(foreach m,$(PKG_MOD_AVAILABLE), \
|
||||
$(if $(CONFIG_PACKAGE_strongswan-mod-$(m)),--enable-$(m),--disable-$(m)) \
|
||||
)
|
||||
) \
|
||||
ac_cv_search___atomic_load=no
|
||||
|
||||
EXTRA_LDFLAGS+= -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
|
||||
|
||||
|
|
|
@ -58,9 +58,9 @@
|
|||
|
||||
+#include <musl.h>
|
||||
+
|
||||
#define _GNU_SOURCE
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <stdint.h>
|
||||
--- a/src/libcharon/plugins/kernel_netlink/kernel_netlink_net.c
|
||||
+++ b/src/libcharon/plugins/kernel_netlink/kernel_netlink_net.c
|
||||
@@ -37,6 +37,8 @@
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- a/src/ipsec/_ipsec.in
|
||||
+++ b/src/ipsec/_ipsec.in
|
||||
@@ -259,7 +259,7 @@ stop)
|
||||
loop=110
|
||||
while [ $loop -gt 0 ] ; do
|
||||
kill -0 $spid 2>/dev/null || break
|
||||
loop=110
|
||||
while [ $loop -gt 0 ] ; do
|
||||
kill -0 $spid 2>/dev/null || break
|
||||
- sleep 0.1 2>/dev/null
|
||||
+ sleep 1 2>/dev/null
|
||||
if [ $? -ne 0 ]
|
||||
then
|
||||
sleep 1
|
||||
if [ $? -ne 0 ]
|
||||
then
|
||||
sleep 1
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -135,6 +135,7 @@ ARG_DISBL_SET([fips-prf], [disable
|
||||
@@ -133,6 +133,7 @@ ARG_DISBL_SET([fips-prf], [disable
|
||||
ARG_ENABL_SET([gcm], [enables the GCM AEAD wrapper crypto plugin.])
|
||||
ARG_ENABL_SET([gcrypt], [enables the libgcrypt plugin.])
|
||||
ARG_DISBL_SET([gmp], [disable GNU MP (libgmp) based crypto implementation plugin.])
|
||||
|
@ -8,7 +8,7 @@
|
|||
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.])
|
||||
ARG_ENABL_SET([md4], [enable MD4 software implementation plugin.])
|
||||
ARG_DISBL_SET([md5], [disable MD5 software implementation plugin.])
|
||||
@@ -1325,6 +1326,7 @@ ADD_PLUGIN([gcrypt], [s ch
|
||||
@@ -1347,6 +1348,7 @@ ADD_PLUGIN([gcrypt], [s ch
|
||||
ADD_PLUGIN([af-alg], [s charon scepclient pki scripts medsrv attest nm cmd aikgen])
|
||||
ADD_PLUGIN([fips-prf], [s charon nm cmd])
|
||||
ADD_PLUGIN([gmp], [s charon scepclient pki scripts manager medsrv attest nm cmd aikgen])
|
||||
|
@ -16,7 +16,7 @@
|
|||
ADD_PLUGIN([agent], [s charon nm cmd])
|
||||
ADD_PLUGIN([keychain], [s charon cmd])
|
||||
ADD_PLUGIN([chapoly], [s charon scripts nm cmd])
|
||||
@@ -1458,6 +1460,7 @@ AM_CONDITIONAL(USE_SHA2, test x$sha2 = x
|
||||
@@ -1480,6 +1482,7 @@ AM_CONDITIONAL(USE_SHA2, test x$sha2 = x
|
||||
AM_CONDITIONAL(USE_SHA3, test x$sha3 = xtrue)
|
||||
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue)
|
||||
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue)
|
||||
|
@ -24,7 +24,7 @@
|
|||
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue)
|
||||
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue)
|
||||
AM_CONDITIONAL(USE_RANDOM, test x$random = xtrue)
|
||||
@@ -1707,6 +1710,7 @@ AC_CONFIG_FILES([
|
||||
@@ -1733,6 +1736,7 @@ AC_CONFIG_FILES([
|
||||
src/libstrongswan/plugins/sha3/Makefile
|
||||
src/libstrongswan/plugins/fips_prf/Makefile
|
||||
src/libstrongswan/plugins/gmp/Makefile
|
||||
|
@ -34,7 +34,7 @@
|
|||
src/libstrongswan/plugins/random/Makefile
|
||||
--- a/src/libstrongswan/Makefile.am
|
||||
+++ b/src/libstrongswan/Makefile.am
|
||||
@@ -305,6 +305,13 @@ if MONOLITHIC
|
||||
@@ -307,6 +307,13 @@ if MONOLITHIC
|
||||
endif
|
||||
endif
|
||||
|
||||
|
|
Loading…
Reference in a new issue