From 100f43e60e30cdedc417e14abdb8b0f03ebd91d3 Mon Sep 17 00:00:00 2001
From: Ian Leonard <antonlacon@gmail.com>
Date: Sun, 26 Jul 2020 00:01:27 -0700
Subject: [PATCH] rsync: drop option for included zlib

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
---
 net/rsync/Config.in | 12 ------------
 net/rsync/Makefile  |  4 ++--
 2 files changed, 2 insertions(+), 14 deletions(-)

diff --git a/net/rsync/Config.in b/net/rsync/Config.in
index ea1c59451..5c297f400 100644
--- a/net/rsync/Config.in
+++ b/net/rsync/Config.in
@@ -12,16 +12,4 @@ if PACKAGE_rsync
 		default y if USE_FS_ACL_ATTR
 		default n
 
-	config RSYNC_zlib
-		bool
-		prompt "Enable system zlib"
-		help 
-			Use the system's zlib library instead of rsync's internal copy. Enabling
-			this may create compatibility errors when using compression  with older
-			clients, or those using the current default of the bundled zlib.
-
-			rsync's upstream default is to use their bundled zlib. OpenWrt uses the
-			system zlib for space reasons. The system zlib will eventually become 
-			default for upstream as well.
-		default y
 endif
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index ca8205ea7..6452def0e 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -30,7 +30,7 @@ define Package/rsync
   CATEGORY:=Network
   SUBMENU:=File Transfer
   TITLE:=Fast remote file copy program (like rcp)
-  DEPENDS:=+libpopt +RSYNC_xattr:libattr +RSYNC_acl:libacl +RSYNC_zlib:zlib
+  DEPENDS:=+libpopt +zlib +RSYNC_xattr:libattr +RSYNC_acl:libacl
   URL:=https://rsync.samba.org/
   MENU:=1
 endef
@@ -43,6 +43,7 @@ TARGET_CFLAGS += $(if $(CONFIG_IPV6),-DINET6,)
 
 CONFIGURE_ARGS += \
 	--without-included-popt \
+	--without-included-zlib \
 	--disable-debug \
 	--disable-asm \
 	--disable-iconv \
@@ -56,7 +57,6 @@ CONFIGURE_ARGS += \
 	--disable-zstd \
 	--$(if $(CONFIG_RSYNC_xattr),en,dis)able-xattr-support \
 	--$(if $(CONFIG_RSYNC_acl),en,dis)able-acl-support \
-	--with$(if $(CONFIG_RSYNC_zlib),,out)-included-zlib \
 	$(if $(CONFIG_IPV6),,--disable-ipv6)
 
 define Package/rsyncd