liburing: Update to v0.7
- Updated download URL and hash - Removed our include-patch as the problem was fixed upstream - Removed our MUSL-specific loff_t definition as liburing switched to off_t which is supported by MUSL out-of-the-box Signed-off-by: Christian Lachner <gladiac@gmail.com>
This commit is contained in:
parent
147a5f7e31
commit
0fbe6944d0
2 changed files with 2 additions and 15 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=liburing
|
||||
PKG_VERSION:=0.6
|
||||
PKG_VERSION:=0.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://git.kernel.dk/cgit/liburing/snapshot
|
||||
PKG_HASH:=44c99b9f148a885d882acd7aa63658141675eae251298cbf79bb9a4ab307ef9c
|
||||
PKG_HASH:=05d0cf8493d573c76b11abfcf34aabc7153affebe17ff95f9ae88b0de062a59d
|
||||
|
||||
PKG_MAINTAINER:=Christian Lachner <gladiac@gmail.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
@ -33,8 +33,6 @@ endef
|
|||
|
||||
CONFIGURE_ARGS:=--prefix=$(CONFIGURE_PREFIX) --cc=${TARGET_CC}
|
||||
|
||||
TARGET_CFLAGS += $(if $(CONFIG_USE_MUSL),-Dloff_t=off_t)
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) $(PKG_BUILD_DIR) \
|
||||
DSTROOT="$(PKG_INSTALL_DIR)"
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ./configure
|
||||
+++ ./configure
|
||||
@@ -301,6 +301,8 @@
|
||||
fi
|
||||
if test "$__kernel_timespec" != "yes"; then
|
||||
cat >> $compat_h << EOF
|
||||
+#include <inttypes.h>
|
||||
+
|
||||
struct __kernel_timespec {
|
||||
int64_t tv_sec;
|
||||
long long tv_nsec;
|
Loading…
Reference in a new issue