libdaq: revert back to 2.2.2 in anticipation of libdaq3 package
Snort 3.0.3-1 requires libdaq 3.0.0-beta1, but this version is no longer compatible with Snort 2. This reverts libdaq to 2.2.2 so that Snort 2 can compile. A separate libdaq3 package with allow Snort 3 to compile. Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
70e4e85788
commit
0de5145814
3 changed files with 69 additions and 5 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libdaq
|
||||
PKG_VERSION:=3.0.0-beta1
|
||||
PKG_VERSION:=2.2.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=https://www.snort.org/downloads/snortplus/
|
||||
PKG_SOURCE:=daq-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=ef74aa1c30a6ee93eacbe7967d1c85d7df3214cf3783d4eabbb6b64305fd273e
|
||||
PKG_HASH:=7cd818cabb1ad35360e83076e54775f07165ee71407dc672d147e27d3cd37f7b
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/daq-$(PKG_VERSION)
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
@ -29,7 +29,7 @@ define Package/libdaq
|
|||
CATEGORY:=Libraries
|
||||
TITLE:=DAQ library
|
||||
URL:=$(PKG_SOURCE_URL)
|
||||
DEPENDS:=+libdnet +libpcap +libstdcpp
|
||||
DEPENDS:=+libdnet +libpcap
|
||||
endef
|
||||
|
||||
define Package/libdaq/description
|
||||
|
@ -52,7 +52,7 @@ define Build/InstallDev
|
|||
$(INSTALL_DIR) $(STAGING_DIR)/usr/lib/daq
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/* $(STAGING_DIR)/usr/lib/daq/
|
||||
$(INSTALL_DIR) $(STAGING_DIR)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(STAGING_DIR)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daq-modules-config $(STAGING_DIR)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/libdaq/install
|
||||
|
@ -61,7 +61,7 @@ define Package/libdaq/install
|
|||
$(INSTALL_DIR) $(1)/usr/lib/daq
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/*.so* $(1)/usr/lib/daq/
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daq-modules-config $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libdaq))
|
||||
|
|
19
libs/libdaq/patches/001-compile.patch
Normal file
19
libs/libdaq/patches/001-compile.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
diff -u --recursive daq-2.2.2-vanilla/configure daq-2.2.2/configure
|
||||
--- daq-2.2.2-vanilla/configure 2017-07-05 15:58:03.000000000 -0400
|
||||
+++ daq-2.2.2/configure 2018-09-01 17:18:56.774898034 -0400
|
||||
@@ -13244,10 +13244,11 @@
|
||||
else
|
||||
|
||||
if test "$cross_compiling" = yes; then :
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
-See \`config.log' for more details" "$LINENO" 5; }
|
||||
+# { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
+#$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
+#as_fn_error $? "cannot run test program while cross compiling
|
||||
+#See \`config.log' for more details" "$LINENO" 5; }
|
||||
+ echo " No cross compiling test."
|
||||
else
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
/* end confdefs.h. */
|
45
libs/libdaq/patches/100-musl-compat.patch
Normal file
45
libs/libdaq/patches/100-musl-compat.patch
Normal file
|
@ -0,0 +1,45 @@
|
|||
diff -u --recursive daq-2.2.2-vanilla/os-daq-modules/daq_ipfw.c daq-2.2.2/os-daq-modules/daq_ipfw.c
|
||||
--- daq-2.2.2-vanilla/os-daq-modules/daq_ipfw.c 2017-02-08 17:04:18.000000000 -0500
|
||||
+++ daq-2.2.2/os-daq-modules/daq_ipfw.c 2018-09-01 17:21:10.608181841 -0400
|
||||
@@ -23,10 +23,10 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <stdio.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/time.h>
|
||||
-#include <sys/unistd.h>
|
||||
|
||||
#include <netinet/in.h>
|
||||
#include <sys/socket.h>
|
||||
diff -u --recursive daq-2.2.2-vanilla/os-daq-modules/daq_ipq.c daq-2.2.2/os-daq-modules/daq_ipq.c
|
||||
--- daq-2.2.2-vanilla/os-daq-modules/daq_ipq.c 2017-02-08 17:04:18.000000000 -0500
|
||||
+++ daq-2.2.2/os-daq-modules/daq_ipq.c 2018-09-01 17:21:23.162208457 -0400
|
||||
@@ -24,10 +24,10 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/time.h>
|
||||
-#include <sys/unistd.h>
|
||||
|
||||
#include <netinet/ip.h>
|
||||
|
||||
diff -u --recursive daq-2.2.2-vanilla/os-daq-modules/daq_nfq.c daq-2.2.2/os-daq-modules/daq_nfq.c
|
||||
--- daq-2.2.2-vanilla/os-daq-modules/daq_nfq.c 2017-02-08 17:04:18.000000000 -0500
|
||||
+++ daq-2.2.2/os-daq-modules/daq_nfq.c 2018-09-01 17:21:35.202233988 -0400
|
||||
@@ -24,10 +24,10 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/time.h>
|
||||
-#include <sys/unistd.h>
|
||||
|
||||
#include <netinet/ip.h>
|
||||
|
Loading…
Reference in a new issue