diff --git a/net/apinger/Makefile b/net/apinger/Makefile
index 1c52c7578..f6837cec4 100644
--- a/net/apinger/Makefile
+++ b/net/apinger/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=apinger
 PKG_SOURCE_DATE:=2015-04-09
 PKG_SOURCE_VERSION:=78eb328721ba1a10571c19df95acddcb5f0c17c8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/Jajcus/apinger
diff --git a/net/apinger/patches/020-gcc10.patch b/net/apinger/patches/020-gcc10.patch
new file mode 100644
index 000000000..32728048c
--- /dev/null
+++ b/net/apinger/patches/020-gcc10.patch
@@ -0,0 +1,11 @@
+--- a/src/apinger.h
++++ b/src/apinger.h
+@@ -111,7 +111,7 @@ struct piped_info {
+ };
+ #endif
+ 
+-struct target *targets;
++extern struct target *targets;
+ 
+ extern int foreground;
+ extern char *config_file;