lvm2: update to version 2.02.164
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
4944d6e1b5
commit
0d3a10e3b4
4 changed files with 10 additions and 26 deletions
|
@ -9,13 +9,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=LVM2
|
||||
PKG_VERSION:=2.02.161
|
||||
PKG_VERSION:=2.02.164
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=GPL-2.0 LGPL-2.1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2/releases
|
||||
PKG_MD5SUM:=3cd2620a3c7f7f84171bb028130b9816e885ab244a2e2aadff22bc1493c91c19
|
||||
PKG_MD5SUM:=96dbbfe0b06191eac0e795bc40cdffcc8b10f809e26ac1e46fef16ef34264619
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
|
||||
|
||||
|
|
|
@ -1,17 +1,6 @@
|
|||
--- a/lib/commands/toolcontext.c
|
||||
+++ b/lib/commands/toolcontext.c
|
||||
@@ -1785,8 +1785,10 @@ struct cmd_context *create_toolcontext(u
|
||||
unsigned set_filters)
|
||||
{
|
||||
struct cmd_context *cmd;
|
||||
+#if defined(__GLIBC__) && !defined(VALGRIND_POOL)
|
||||
FILE *new_stream;
|
||||
int flags;
|
||||
+#endif
|
||||
|
||||
#ifdef M_MMAP_MAX
|
||||
mallopt(M_MMAP_MAX, 0);
|
||||
@@ -1822,7 +1824,7 @@ struct cmd_context *create_toolcontext(u
|
||||
@@ -1843,7 +1843,7 @@ struct cmd_context *create_toolcontext(u
|
||||
/* FIXME Make this configurable? */
|
||||
reset_lvm_errno(1);
|
||||
|
||||
|
@ -20,7 +9,7 @@
|
|||
/* Set in/out stream buffering before glibc */
|
||||
if (set_buffering) {
|
||||
/* Allocate 2 buffers */
|
||||
@@ -2205,7 +2207,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
@@ -2224,7 +2224,7 @@ void destroy_toolcontext(struct cmd_cont
|
||||
if (cmd->libmem)
|
||||
dm_pool_destroy(cmd->libmem);
|
||||
|
||||
|
@ -31,7 +20,7 @@
|
|||
if (is_valid_fd(STDIN_FILENO) &&
|
||||
--- a/tools/lvmcmdline.c
|
||||
+++ b/tools/lvmcmdline.c
|
||||
@@ -1782,6 +1782,7 @@ int lvm_split(char *str, int *argc, char
|
||||
@@ -1815,6 +1815,7 @@ int lvm_split(char *str, int *argc, char
|
||||
/* Make sure we have always valid filedescriptors 0,1,2 */
|
||||
static int _check_standard_fds(void)
|
||||
{
|
||||
|
@ -39,7 +28,7 @@
|
|||
int err = is_valid_fd(STDERR_FILENO);
|
||||
|
||||
if (!is_valid_fd(STDIN_FILENO) &&
|
||||
@@ -1808,6 +1809,12 @@ static int _check_standard_fds(void)
|
||||
@@ -1841,6 +1842,12 @@ static int _check_standard_fds(void)
|
||||
strerror(errno));
|
||||
return 0;
|
||||
}
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/mm/memlock.c
|
||||
+++ b/lib/mm/memlock.c
|
||||
@@ -169,12 +169,15 @@ static void _allocate_memory(void)
|
||||
@@ -174,12 +174,15 @@ static void _allocate_memory(void)
|
||||
* memory on free(), this is good enough for our purposes.
|
||||
*/
|
||||
while (missing > 0) {
|
||||
|
@ -16,7 +16,7 @@
|
|||
inf = mallinfo();
|
||||
|
||||
if (hblks < inf.hblks) {
|
||||
@@ -184,9 +187,12 @@ static void _allocate_memory(void)
|
||||
@@ -189,9 +192,12 @@ static void _allocate_memory(void)
|
||||
free(areas[area]);
|
||||
_size_malloc_tmp /= 2;
|
||||
} else {
|
||||
|
@ -29,7 +29,7 @@
|
|||
|
||||
if (area == max_areas && missing > 0) {
|
||||
/* Too bad. Warn the user and proceed, as things are
|
||||
@@ -475,8 +481,13 @@ static void _lock_mem(struct cmd_context
|
||||
@@ -480,8 +486,13 @@ static void _lock_mem(struct cmd_context
|
||||
* will not block memory locked thread
|
||||
* Note: assuming _memlock_count_daemon is updated before _memlock_count
|
||||
*/
|
||||
|
|
|
@ -13,11 +13,9 @@ on standard C libraries without O_DIRECT_SUPPORT.
|
|||
lib/device/dev-io.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/device/dev-io.c b/lib/device/dev-io.c
|
||||
index a9a2374..4d71967 100644
|
||||
--- a/lib/device/dev-io.c
|
||||
+++ b/lib/device/dev-io.c
|
||||
@@ -529,7 +529,7 @@ int dev_open_flags(struct device *dev, int flags, int direct, int quiet)
|
||||
@@ -529,7 +529,7 @@ int dev_open_flags(struct device *dev, i
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -26,6 +24,3 @@ index a9a2374..4d71967 100644
|
|||
opened:
|
||||
if (direct)
|
||||
dev->flags |= DEV_O_DIRECT_TESTED;
|
||||
--
|
||||
2.8.2
|
||||
|
||||
|
|
Loading…
Reference in a new issue