diff --git a/libs/libowfat/Makefile b/libs/libowfat/Makefile
index e93262509..9f9fc742d 100644
--- a/libs/libowfat/Makefile
+++ b/libs/libowfat/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libowfat
 PKG_VERSION:=0.32
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.fefe.de/libowfat
diff --git a/libs/libowfat/patches/012-remove-deprecated.patch b/libs/libowfat/patches/012-remove-deprecated.patch
new file mode 100644
index 000000000..49e3c824c
--- /dev/null
+++ b/libs/libowfat/patches/012-remove-deprecated.patch
@@ -0,0 +1,16 @@
+--- a/scan/scan_iso8601.c
++++ b/scan/scan_iso8601.c
+@@ -1,5 +1,4 @@
+ #define _GNU_SOURCE
+-#define __deprecated__
+ #include "scan.h"
+ #include "byte.h"
+ #include "case.h"
+--- a/scan/scan_httpdate.c
++++ b/scan/scan_httpdate.c
+@@ -1,5 +1,4 @@
+ #define _GNU_SOURCE
+-#define __deprecated__
+ #include "scan.h"
+ #include "byte.h"
+ #include "case.h"