lttng-ust: import from old packages feed
- update to latest version (v2.6.0) - add license info - add myself as maintainer Signed-off-by: Nicolas Thill <nico@openwrt.org>
This commit is contained in:
parent
53ea5955bd
commit
0bb5f29415
3 changed files with 80 additions and 0 deletions
51
libs/lttng-ust/Makefile
Normal file
51
libs/lttng-ust/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
|||
#
|
||||
# Copyright (C) 2013-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lttng-ust
|
||||
PKG_VERSION:=2.6.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
|
||||
PKG_MD5SUM:=74ad4826eac76c9dbf50fd3e46523191
|
||||
|
||||
PKG_LICENSE:=LGPL-2.1 GPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_USE_MIPS16:=0
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/lttng-ust
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Linux Trace Toolkit: next generation (library)
|
||||
URL:=https://lttng.org/
|
||||
DEPENDS:= +liburcu +libuuid +librt
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/lttng $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.{a,so*} $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ust.pc $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/lttng-ust/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng*.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,lttng-ust))
|
11
libs/lttng-ust/patches/001-no_docs_tests.patch
Normal file
11
libs/lttng-ust/patches/001-no_docs_tests.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -20,8 +20,6 @@ if BUILD_JAVA_AGENT
|
||||
SUBDIRS += liblttng-ust-java-agent
|
||||
endif
|
||||
|
||||
-SUBDIRS += tests doc
|
||||
-
|
||||
#temporarily disabled
|
||||
# liblttng-ust-malloc
|
||||
|
18
libs/lttng-ust/patches/002-examples.patch
Normal file
18
libs/lttng-ust/patches/002-examples.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -350,7 +350,14 @@ AC_ARG_WITH([lttng-system-rundir],
|
||||
AC_DEFINE_UNQUOTED([LTTNG_SYSTEM_RUNDIR], ["$lttng_system_rundir"],
|
||||
[LTTng system runtime directory])
|
||||
|
||||
-AM_PATH_PYTHON([2.7],BUILD_GEN_TP_EXAMPLES=1,[:])
|
||||
+AC_ARG_ENABLE([examples],
|
||||
+ [AS_HELP_STRING([--enable-examples],[build examples [default=no]])],
|
||||
+ [enable_examples=$enableval],
|
||||
+ [enable_examples=no]
|
||||
+)
|
||||
+if test "x$enable_examples" = "xyes"; then
|
||||
+ AM_PATH_PYTHON([2.7],BUILD_GEN_TP_EXAMPLES=1,[:])
|
||||
+fi
|
||||
AM_CONDITIONAL([BUILD_GEN_TP_EXAMPLES], [test $BUILD_GEN_TP_EXAMPLES], [Build examples requiring lttng-gen-tp])
|
||||
|
||||
AC_CONFIG_FILES([
|
Loading…
Reference in a new issue