node: bump to v16.18.0
Update to v16.18.0
Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
(cherry picked from commit 5851aa8062
)
This commit is contained in:
parent
f916e3426b
commit
0b68bfd6c0
6 changed files with 25 additions and 12 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=node
|
||||
PKG_VERSION:=v16.17.1
|
||||
PKG_VERSION:=v16.18.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
|
||||
PKG_HASH:=6721feb4152d56d2c6b358ce397abd5a7f1daf09ee2e25c5021b9b4d3f86a330
|
||||
PKG_HASH:=fcfe6ad2340f229061d3e81a94df167fe3f77e01712dedc0144a0e7d58e2c69b
|
||||
|
||||
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/internal/modules/cjs/loader.js
|
||||
+++ b/lib/internal/modules/cjs/loader.js
|
||||
@@ -1261,7 +1261,8 @@ Module._initPaths = function() {
|
||||
@@ -1290,7 +1290,8 @@ Module._initPaths = function() {
|
||||
path.resolve(process.execPath, '..') :
|
||||
path.resolve(process.execPath, '..', '..');
|
||||
|
||||
|
|
|
@ -34,7 +34,7 @@
|
|||
'<@(icu_src_genccode)',
|
||||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -1365,6 +1365,7 @@
|
||||
@@ -1373,6 +1373,7 @@
|
||||
{
|
||||
'target_name': 'bytecode_builtins_list_generator',
|
||||
'type': 'executable',
|
||||
|
@ -42,7 +42,7 @@
|
|||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1389,6 +1390,8 @@
|
||||
@@ -1397,6 +1398,8 @@
|
||||
{
|
||||
'target_name': 'mksnapshot',
|
||||
'type': 'executable',
|
||||
|
@ -51,7 +51,7 @@
|
|||
'dependencies': [
|
||||
'v8_base_without_compiler',
|
||||
'v8_compiler_for_mksnapshot',
|
||||
@@ -1410,6 +1413,7 @@
|
||||
@@ -1418,6 +1421,7 @@
|
||||
{
|
||||
'target_name': 'torque',
|
||||
'type': 'executable',
|
||||
|
@ -59,7 +59,7 @@
|
|||
'dependencies': [
|
||||
'torque_base',
|
||||
# "build/win:default_exe_manifest",
|
||||
@@ -1448,6 +1452,7 @@
|
||||
@@ -1456,6 +1460,7 @@
|
||||
{
|
||||
'target_name': 'torque-language-server',
|
||||
'type': 'executable',
|
||||
|
@ -67,7 +67,7 @@
|
|||
'conditions': [
|
||||
['want_separate_host_toolset', {
|
||||
'toolsets': ['host'],
|
||||
@@ -1475,6 +1480,8 @@
|
||||
@@ -1483,6 +1488,8 @@
|
||||
{
|
||||
'target_name': 'gen-regexp-special-case',
|
||||
'type': 'executable',
|
||||
|
|
|
@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
|
|||
//
|
||||
// Permission is hereby granted, free of charge, to any person obtaining a
|
||||
// copy of this software and associated documentation files (the
|
||||
@@ -1118,13 +1119,6 @@ function lookupAndConnect(self, options)
|
||||
@@ -1149,13 +1150,6 @@ function lookupAndConnect(self, options)
|
||||
hints: options.hints || 0
|
||||
};
|
||||
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -1241,10 +1241,6 @@ def configure_node(o):
|
||||
|
||||
o['variables']['want_separate_host_toolset'] = int(cross_compiling)
|
||||
|
||||
- # Enable branch protection for arm64
|
||||
- if target_arch == 'arm64':
|
||||
- o['cflags']+=['-msign-return-address=all']
|
||||
-
|
||||
if options.node_snapshot_main is not None:
|
||||
if options.shared:
|
||||
# This should be possible to fix, but we will need to refactor the
|
|
@ -59,7 +59,7 @@
|
|||
'include_dirs': [
|
||||
'<(generate_bytecode_output_root)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)',
|
||||
@@ -1345,6 +1351,7 @@
|
||||
@@ -1353,6 +1359,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
|
@ -67,7 +67,7 @@
|
|||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1693,6 +1700,7 @@
|
||||
@@ -1701,6 +1708,7 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
|
@ -75,7 +75,7 @@
|
|||
'include_dirs': [
|
||||
'<(V8_ROOT)/include',
|
||||
],
|
||||
@@ -1873,15 +1881,19 @@
|
||||
@@ -1881,15 +1889,19 @@
|
||||
}],
|
||||
],
|
||||
'direct_dependent_settings': {
|
||||
|
|
Loading…
Reference in a new issue