Merge pull request #7157 from neheb/hid

hiredis: Update to 0.14.0
This commit is contained in:
Hannu Nyman 2018-10-28 14:35:05 +02:00 committed by GitHub
commit 0ac9ccb718
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 4 additions and 16 deletions

View file

@ -8,17 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hiredis
PKG_VERSION:=0.13.3
PKG_RELEASE:=2
PKG_VERSION:=0.14.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/redis/hiredis/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=717e6fc8dc2819bef522deaca516de9e51b9dfa68fe393b7db5c3b6079196f78
PKG_HASH:=042f965e182b80693015839a9d0278ae73fae5d5d09d8bf6d0e6a39a8c4393bd
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk

View file

@ -1,13 +0,0 @@
Index: hiredis-0.13.3/hiredis.h
===================================================================
--- hiredis-0.13.3.orig/hiredis.h
+++ hiredis-0.13.3/hiredis.h
@@ -98,7 +98,7 @@
* then GNU strerror_r returned an internal static buffer and we \
* need to copy the result into our private buffer. */ \
if (err_str != (buf)) { \
- buf[(len)] = '\0'; \
+ (buf)[(len)] = '\0'; \
strncat((buf), err_str, ((len) - 1)); \
} \
} while (0)