rtorrent: Update to 0.9.8
Switch to codeload. A lot simpler.
Remove upstreamed patch.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 84c92f215d
)
This commit is contained in:
parent
df85170032
commit
09ee71062e
2 changed files with 8 additions and 25 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtorrent
|
||||
PKG_VERSION:=0.9.7
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.9.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent/releases/download/v$(PKG_VERSION)
|
||||
PKG_HASH:=5d9842fe48c9582fbea2c7bf9f51412c1ccbba07d059b257039ad53b863fe8bb
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/rakshasa/rtorrent/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=bc889ce1dde475ec56aa72ae996912ff58723226a4f4256fef4f1f8636d991d4
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||
|
@ -23,6 +23,7 @@ PKG_LICENSE_FILES:=COPYING
|
|||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_REMOVE_FILES:=autogen.sh
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -32,7 +33,7 @@ define Package/rtorrent/Default
|
|||
CATEGORY:=Network
|
||||
TITLE:=BitTorrent client for ncurses
|
||||
URL:=https://github.com/rakshasa/rtorrent
|
||||
DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +libpthread
|
||||
DEPENDS:=+libcurl +libtorrent +libncurses +libpthread
|
||||
endef
|
||||
|
||||
define Package/rtorrent/Default/description
|
||||
|
@ -76,6 +77,8 @@ ifeq ($(BUILD_VARIANT),rpc)
|
|||
CONFIGURE_ARGS += --with-xmlrpc-c
|
||||
endif
|
||||
|
||||
TARGET_CXXFLAGS += -faligned-new
|
||||
|
||||
define Package/rtorrent/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- a/scripts/common.m4
|
||||
+++ b/scripts/common.m4
|
||||
@@ -153,7 +153,7 @@ dnl Need to fix this so that it uses t
|
||||
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
||||
AC_MSG_CHECKING(for execinfo.h)
|
||||
|
||||
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
||||
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
||||
#include <execinfo.h>
|
||||
int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
|
||||
])],
|
||||
@@ -168,7 +168,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
||||
AC_DEFUN([TORRENT_CHECK_ALIGNED], [
|
||||
AC_MSG_CHECKING(the byte alignment)
|
||||
|
||||
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
||||
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
||||
#include <inttypes.h>
|
||||
int main() {
|
||||
char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };
|
Loading…
Reference in a new issue