diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 6ac6051fa..dc30494fe 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -37,6 +37,10 @@ define PyPackage
 		IFS='|'; \
 		while read fop fspec fperm; do \
 		  if [ "$$$$$$$$fop" = "+" ]; then \
+			if [ ! -e "$(PKG_INSTALL_DIR)$$$$$$$$fspec" ]; then \
+			  echo "File not found '$(PKG_INSTALL_DIR)$$$$$$$$fspec'"; \
+			  exit 1; \
+			fi; \
 			dpath=`dirname "$$$$$$$$fspec"`; \
 			if [ -n "$$$$$$$$fperm" ]; then \
 			  dperm="-m$$$$$$$$fperm"; \