Merge pull request #1469 from jow-/squid-musl-compat

squid: fix musl compatibility
This commit is contained in:
Luka Perkov 2015-06-25 22:04:35 +02:00
commit 0983670143
2 changed files with 16 additions and 1 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=squid
PKG_VERSION:=3.5.2
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>

View file

@ -0,0 +1,15 @@
--- a/lib/rfcnb/rfcnb-io.c
+++ b/lib/rfcnb/rfcnb-io.c
@@ -36,11 +36,11 @@
#include "rfcnb/rfcnb-util.h"
#include "rfcnb/std-includes.h"
+#include <signal.h>
#if HAVE_STRING_H
#include <string.h>
#endif
#include <sys/uio.h>
-#include <sys/signal.h>
int RFCNB_Timeout = 0; /* Timeout in seconds ... */