ntfs-3g: Update to 2017.3.23 version, provide single utilites package, refresh patches
Changes to NTFS-3G: Delegated processing of special reparse points to external plugins Allowed kernel cacheing by lowntfs-3g when not using Posix ACLs Enabled fallback to read-only mount when the volume is hibernated Made a full check for whether an extended attribute is allowed Moved secaudit and usermap to ntfsprogs (now ntfssecaudit and ntfsusermap) Enabled encoding broken UTF-16 into broken UTF-8 Autoconfigured selecting <sys/sysmacros.h> vs <sys/mkdev> Allowed using the full library API on systems without extended attributes support Fixed DISABLE_PLUGINS as the condition for not using plugins Corrected validation of multi sector transfer protected records Denied creating/removing files from $Extend Returned the size of locale encoded target as the size of symlinks http://www.tuxera.com/community/release-history/ Signed-off-by: BangLang Huang <banglang.huang@foxmail.com> Make ntfs-3g-utils into a single package due to upstream package changes. Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
69187e794a
commit
092b4d0ae8
2 changed files with 17 additions and 42 deletions
|
@ -1,6 +1,4 @@
|
|||
#
|
||||
# Copyright (C) 2007-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
@ -10,10 +8,10 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=ntfs-3g
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_VERSION:=2016.2.22
|
||||
PKG_VERSION:=2017.3.23
|
||||
PKG_SOURCE:=$(PKG_NAME)_ntfsprogs-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=http://www.tuxera.com/opensource/
|
||||
PKG_MD5SUM:=ccbe8672d0f757bd0c975b50aa4c512e
|
||||
PKG_SOURCE_URL:=https://www.tuxera.com/opensource/
|
||||
PKG_HASH:=3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5
|
||||
|
||||
PKG_LICENSE:=GPL-2.0 LGPL-2.0
|
||||
PKG_LICENSE_FILES:=COPYING COPYING.LIB
|
||||
|
@ -87,22 +85,8 @@ define Package/ntfs-3g-low/description
|
|||
|
||||
endef
|
||||
|
||||
define Package/ntfs-3g-utils
|
||||
$(call Package/ntfs-3g/common)
|
||||
TITLE:=ntfs-3g utilities (extra)
|
||||
DEPENDS+= +ntfs-3g
|
||||
endef
|
||||
|
||||
define Package/ntfs-3g-utils/description
|
||||
Additional ntfs-3g utilities. Not included by default for size
|
||||
considerations.
|
||||
|
||||
Currently:
|
||||
- ntfs-3g.secaudit
|
||||
- ntfs-3g.usermap
|
||||
endef
|
||||
|
||||
define Package/ntfsprogs_ntfs-3g/description
|
||||
Suite of NTFS utilities for doing neat things with NTFS.
|
||||
Contains:
|
||||
- mkntfs - Create an NTFS filesystem.
|
||||
|
@ -111,17 +95,19 @@ define Package/ntfsprogs_ntfs-3g/description
|
|||
- ntfscluster - Locate the files which use the given sectors or clusters.
|
||||
- ntfscmp - Compare two NTFS filesystems and tell the differences.
|
||||
- ntfscp - Copy a file to an NTFS volume.
|
||||
- ntfssecaudit - Display ownership and permissions, check consistency
|
||||
- ntfsfix - Check and fix some common errors, clear the LogFile.
|
||||
- ntfsinfo - Show information about NTFS or one of the files or directories within it.
|
||||
- ntfslabel - Show, or set, an NTFS filesystem's volume label.
|
||||
- ntfsls - List information about files in a directory residing on an NTFS.
|
||||
- ntfsresize - Resize NTFS without losing data.
|
||||
- ntfsundelete - Recover deleted files from NTFS.
|
||||
- ntfsusermap - Define mapping of Windows accounts to Linux logins
|
||||
endef
|
||||
|
||||
define Package/ntfsprogs_ntfs-3g
|
||||
define Package/ntfs-3g-utils
|
||||
$(call Package/ntfs-3g/common)
|
||||
TITLE:=ntfsprogs (ntfs-3g)
|
||||
TITLE:=ntfs-3g utilities
|
||||
DEPENDS+= +ntfs-3g +libgcrypt +libuuid
|
||||
endef
|
||||
|
||||
|
@ -139,11 +125,11 @@ else
|
|||
TARGET_CPPFLAGS:=-I../include/fuse-lite $(TARGET_CPPFLAGS)
|
||||
endif
|
||||
|
||||
# enable disable ntfsprogs
|
||||
ifneq ($(CONFIG_PACKAGE_ntfsprogs_ntfs-3g)$(SDK)$(DEVELOPER),)
|
||||
CONFIGURE_ARGS += --enable-ntfsprogs
|
||||
# enable ntfsprogs and extras
|
||||
ifneq ($(CONFIG_PACKAGE_ntfs-3g-utils)$(SDK)$(DEVELOPER),)
|
||||
CONFIGURE_ARGS += --enable-ntfsprogs --enable-extras
|
||||
else
|
||||
CONFIGURE_ARGS += --disable-ntfsprogs
|
||||
CONFIGURE_ARGS += --disable-ntfsprogs --disable-extras
|
||||
endif
|
||||
|
||||
# redefine prepare to extract to our build dir
|
||||
|
@ -214,12 +200,6 @@ fi
|
|||
endef
|
||||
|
||||
define Package/ntfs-3g-utils/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g.secaudit $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g.usermap $(1)/usr/bin
|
||||
endef
|
||||
|
||||
define Package/ntfsprogs_ntfs-3g/install
|
||||
$(INSTALL_DIR) $(1)/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/sbin/mkfs.ntfs $(1)/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
@ -231,4 +211,3 @@ endef
|
|||
$(eval $(call BuildPackage,ntfs-3g))
|
||||
$(eval $(call BuildPackage,ntfs-3g-low))
|
||||
$(eval $(call BuildPackage,ntfs-3g-utils))
|
||||
$(eval $(call BuildPackage,ntfsprogs_ntfs-3g))
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: ntfs-3g-2014.2.15-1-fuseint/libfuse-lite/fusermount.c
|
||||
===================================================================
|
||||
--- ntfs-3g-2014.2.15-1-fuseint.orig/libfuse-lite/fusermount.c
|
||||
+++ ntfs-3g-2014.2.15-1-fuseint/libfuse-lite/fusermount.c
|
||||
@@ -36,6 +36,10 @@
|
||||
--- a/libfuse-lite/fusermount.c
|
||||
+++ b/libfuse-lite/fusermount.c
|
||||
@@ -37,6 +37,10 @@
|
||||
|
||||
#define FUSE_DEV_NEW "/dev/fuse"
|
||||
|
||||
|
@ -13,11 +11,9 @@ Index: ntfs-3g-2014.2.15-1-fuseint/libfuse-lite/fusermount.c
|
|||
#ifndef MS_DIRSYNC
|
||||
#define MS_DIRSYNC 128
|
||||
#endif
|
||||
Index: ntfs-3g-2014.2.15-1-fuseint/libfuse-lite/mount_util.c
|
||||
===================================================================
|
||||
--- ntfs-3g-2014.2.15-1-fuseint.orig/libfuse-lite/mount_util.c
|
||||
+++ ntfs-3g-2014.2.15-1-fuseint/libfuse-lite/mount_util.c
|
||||
@@ -255,6 +255,10 @@ int fuse_mnt_check_fuseblk(void)
|
||||
--- a/libfuse-lite/mount_util.c
|
||||
+++ b/libfuse-lite/mount_util.c
|
||||
@@ -264,6 +264,10 @@ int fuse_mnt_check_fuseblk(void)
|
||||
|
||||
#else /* __SOLARIS__ */
|
||||
|
||||
|
|
Loading…
Reference in a new issue