squid: update to version 4.12
- Fixes CVEs:
CVE-2019-12519
CVE-2019-12520
CVE-2019-12521
CVE-2019-12523
CVE-2019-12524
CVE-2019-12525
CVE-2019-12526
CVE-2019-12527
CVE-2019-12528
CVE-2019-12529
CVE-2019-12824
CVE-2019-12854
CVE-2019-13345
CVE-2019-18676
CVE-2019-18677
CVE-2019-18678
CVE-2019-18679
CVE-2020-8449
CVE-2020-8450
CVE-2020-11945
CVE-2020-14058
CVE-2020-15049
- Remove patch for cross-compilation
The patch should not be included in the OpenWrt at all without any
commit message/description.
Is not needed and there should be used HOST variables instead of BUILD variables (e.g.
HOSTCXX)
However, the BUILDCXX is set in Makefile to HOSTCXX
- Renumber glibc patch and refresh it
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
(cherry picked from commit 3401e29aa7
)
This commit is contained in:
parent
5658fd93f8
commit
0821c5001e
3 changed files with 4 additions and 26 deletions
|
@ -8,14 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=squid
|
PKG_NAME:=squid
|
||||||
PKG_VERSION:=4.6
|
PKG_VERSION:=4.12
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=http://www3.us.squid-cache.org/Versions/v4/ \
|
PKG_SOURCE_URL:=http://www3.us.squid-cache.org/Versions/v4/ \
|
||||||
http://www2.pl.squid-cache.org/Versions/v4/ \
|
http://www2.pl.squid-cache.org/Versions/v4/ \
|
||||||
http://www.squid-cache.org/Versions/v4/
|
http://www.squid-cache.org/Versions/v4/
|
||||||
PKG_HASH:=015bade5d3a4905142c4c605df5c4216471e3d8338079955e0e44b0ae0303d41
|
PKG_HASH:=f42a03c8b3dc020722c88bf1a87da8cb0c087b2f66b41d8256c77ee1b527e317
|
||||||
|
|
||||||
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
|
||||||
PKG_LICENSE:=GPL-2.0-or-later
|
PKG_LICENSE:=GPL-2.0-or-later
|
||||||
|
|
|
@ -1,22 +0,0 @@
|
||||||
From fac6f63a52a2f4cbb3748cd5687eca5409093904 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Marko Ratkaj <marko.ratkaj@sartura.hr>
|
|
||||||
Date: Thu, 20 Apr 2017 15:15:50 +0200
|
|
||||||
Subject: [PATCH] foo
|
|
||||||
|
|
||||||
Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
|
|
||||||
---
|
|
||||||
src/Makefile.in | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/src/Makefile.in
|
|
||||||
+++ b/src/Makefile.in
|
|
||||||
@@ -8385,7 +8385,8 @@
|
|
||||||
|
|
||||||
# cf_gen builds the configuration files.
|
|
||||||
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
|
|
||||||
- $(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
|
||||||
+ g++ -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
|
||||||
+
|
|
||||||
|
|
||||||
# squid.conf.default is built by cf_gen when making cf_parser.cci
|
|
||||||
squid.conf.default squid.conf.documented: cf_parser.cci
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/tools.cc
|
--- a/src/tools.cc
|
||||||
+++ b/src/tools.cc
|
+++ b/src/tools.cc
|
||||||
@@ -582,7 +582,8 @@
|
@@ -582,7 +582,8 @@ enter_suid(void)
|
||||||
}
|
}
|
||||||
#else
|
#else
|
||||||
|
|
Loading…
Reference in a new issue