miredo: add debian reproducibility patch
Refreshed other patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
04c911aeb0
commit
081da5a228
5 changed files with 41 additions and 16 deletions
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=miredo
|
||||
PKG_VERSION:=1.2.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=miredo-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://www.remlab.net/files/miredo/
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/libteredo/debug.h 2009-02-28 23:17:14.000000000 +0300
|
||||
+++ b/libteredo/debug.h 2019-04-07 01:46:48.235087395 +0300
|
||||
@@ -43,8 +43,10 @@
|
||||
--- a/libteredo/debug.h
|
||||
+++ b/libteredo/debug.h
|
||||
@@ -43,8 +43,10 @@ static inline void debug (const char *st
|
||||
# ifdef __linux__
|
||||
# include <errno.h>
|
||||
# include <assert.h>
|
||||
|
@ -13,7 +13,7 @@
|
|||
|
||||
static inline int
|
||||
d_pthread_mutex_init (pthread_mutex_t *mutex, pthread_mutexattr_t *pattr)
|
||||
@@ -57,7 +59,7 @@
|
||||
@@ -57,7 +59,7 @@ d_pthread_mutex_init (pthread_mutex_t *m
|
||||
pthread_mutexattr_init (&attr);
|
||||
}
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- a/libtun6/tun6.c 2012-09-12 17:03:59.000000000 +0400
|
||||
+++ b/libtun6/tun6.c 2019-04-07 02:21:07.439952535 +0300
|
||||
--- a/libtun6/tun6.c
|
||||
+++ b/libtun6/tun6.c
|
||||
@@ -53,7 +53,7 @@
|
||||
const char os_driver[] = "Linux";
|
||||
# define USE_LINUX 1
|
||||
|
@ -9,7 +9,7 @@
|
|||
/*
|
||||
* <linux/ipv6.h> conflicts with <netinet/in.h> and <arpa/inet.h>,
|
||||
* so we've got to declare this structure by hand.
|
||||
@@ -65,7 +65,7 @@
|
||||
@@ -65,7 +65,7 @@ struct in6_ifreq {
|
||||
};
|
||||
|
||||
# include <net/route.h> // struct in6_rtmsg
|
||||
|
@ -18,4 +18,3 @@
|
|||
|
||||
typedef struct
|
||||
{
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/gettext.h 2012-09-12 16:57:52.000000000 +0400
|
||||
+++ b/include/gettext.h 2019-04-07 01:11:52.492519796 +0300
|
||||
@@ -182,7 +182,7 @@
|
||||
--- a/include/gettext.h
|
||||
+++ b/include/gettext.h
|
||||
@@ -182,7 +182,7 @@ npgettext_aux (const char *domain,
|
||||
(((__GNUC__ >= 3 || __GNUG__ >= 2) && !defined(__STRICT_ANSI__)) \
|
||||
/* || __STDC_VERSION__ >= 199901L */ )
|
||||
|
||||
|
@ -9,7 +9,7 @@
|
|||
#include <stdlib.h>
|
||||
#endif
|
||||
|
||||
@@ -206,7 +206,7 @@
|
||||
@@ -206,7 +206,7 @@ dcpgettext_expr (const char *domain,
|
||||
size_t msgctxt_len = strlen (msgctxt) + 1;
|
||||
size_t msgid_len = strlen (msgid) + 1;
|
||||
const char *translation;
|
||||
|
@ -18,7 +18,7 @@
|
|||
char msg_ctxt_id[msgctxt_len + msgid_len];
|
||||
#else
|
||||
char buf[1024];
|
||||
@@ -221,7 +221,7 @@
|
||||
@@ -221,7 +221,7 @@ dcpgettext_expr (const char *domain,
|
||||
msg_ctxt_id[msgctxt_len - 1] = '\004';
|
||||
memcpy (msg_ctxt_id + msgctxt_len, msgid, msgid_len);
|
||||
translation = dcgettext (domain, msg_ctxt_id, category);
|
||||
|
@ -27,7 +27,7 @@
|
|||
if (msg_ctxt_id != buf)
|
||||
free (msg_ctxt_id);
|
||||
#endif
|
||||
@@ -252,7 +252,7 @@
|
||||
@@ -252,7 +252,7 @@ dcnpgettext_expr (const char *domain,
|
||||
size_t msgctxt_len = strlen (msgctxt) + 1;
|
||||
size_t msgid_len = strlen (msgid) + 1;
|
||||
const char *translation;
|
||||
|
@ -36,7 +36,7 @@
|
|||
char msg_ctxt_id[msgctxt_len + msgid_len];
|
||||
#else
|
||||
char buf[1024];
|
||||
@@ -267,7 +267,7 @@
|
||||
@@ -267,7 +267,7 @@ dcnpgettext_expr (const char *domain,
|
||||
msg_ctxt_id[msgctxt_len - 1] = '\004';
|
||||
memcpy (msg_ctxt_id + msgctxt_len, msgid, msgid_len);
|
||||
translation = dcngettext (domain, msg_ctxt_id, msgid_plural, n, category);
|
||||
|
|
26
ipv6/miredo/patches/004-reproducible.patch
Normal file
26
ipv6/miredo/patches/004-reproducible.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From: Tomasz Buchert <tomasz@debian.org>
|
||||
Date: Fri, 6 Feb 2015 11:33:20 +0100
|
||||
Subject: Fix reproducibility issues
|
||||
|
||||
We replace unreproducible CC macros with
|
||||
N/A placeholders. This fixes #776716.
|
||||
---
|
||||
src/main.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
--- a/src/main.c
|
||||
+++ b/src/main.c
|
||||
@@ -92,10 +92,11 @@ miredo_version (void)
|
||||
#ifndef VERSION
|
||||
# define VERSION "unknown version"
|
||||
#endif
|
||||
+ const char* UNKNOWN = "N/A";
|
||||
printf (_("Miredo: Teredo IPv6 tunneling software %s (%s)\n"
|
||||
" built %s on %s (%s)\n"),
|
||||
- VERSION, PACKAGE_HOST, __DATE__,
|
||||
- PACKAGE_BUILD_HOSTNAME, PACKAGE_BUILD);
|
||||
+ VERSION, UNKNOWN, UNKNOWN,
|
||||
+ UNKNOWN, UNKNOWN);
|
||||
printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
|
||||
puts (_("Written by Remi Denis-Courmont.\n"));
|
||||
|
Loading…
Reference in a new issue