From 07cef285bf7b19b3d0de30bbb83efe975689bdaf Mon Sep 17 00:00:00 2001
From: Hannu Nyman <hannu.nyman@iki.fi>
Date: Sat, 1 Feb 2020 10:18:54 +0200
Subject: [PATCH] zip: rename package to infozip to avoid name collision with
 tools

Rename "zip" to "infozip" to avoid name collision, as the same
zip package has been introduces to the build tools as zip.
Buildbot does not like that.

Reference to #10985 and #11089 as well as
https://github.com/openwrt/openwrt/commit/ad8c2d6099a7da5192ee6e2c52a8303642271877

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
---
 utils/{zip => infozip}/Makefile                      | 12 ++++++------
 ...onfigure-borrow-the-LFS-test-from-autotools.patch |  0
 .../patches/010-remove-build-date.patch              |  0
 utils/{zip => infozip}/patches/020-format.patch      |  0
 4 files changed, 6 insertions(+), 6 deletions(-)
 rename utils/{zip => infozip}/Makefile (87%)
 rename utils/{zip => infozip}/patches/001-unix-configure-borrow-the-LFS-test-from-autotools.patch (100%)
 rename utils/{zip => infozip}/patches/010-remove-build-date.patch (100%)
 rename utils/{zip => infozip}/patches/020-format.patch (100%)

diff --git a/utils/zip/Makefile b/utils/infozip/Makefile
similarity index 87%
rename from utils/zip/Makefile
rename to utils/infozip/Makefile
index cdd6212f6..f15e635cb 100644
--- a/utils/zip/Makefile
+++ b/utils/infozip/Makefile
@@ -7,12 +7,12 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=zip
+PKG_NAME:=infozip
 PKG_REV:=30
 PKG_VERSION:=3.0
 PKG_RELEASE:=5
 
-PKG_SOURCE:=$(PKG_NAME)$(PKG_REV).tar.gz
+PKG_SOURCE:=zip$(PKG_REV).tar.gz
 PKG_SOURCE_URL:=@SF/infozip
 PKG_HASH:=f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/zip$(PKG_REV)
@@ -26,7 +26,7 @@ PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/zip
+define Package/infozip
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Archiver for .zip files
@@ -34,7 +34,7 @@ define Package/zip
   SUBMENU:=Compression
 endef
 
-define Package/zip/description
+define Package/infozip/description
 	This is InfoZIP's zip program. It produces files that are fully
 	compatible with the popular PKZIP program; however, the command line
 	options are not identical. In other words, the end result is the same,
@@ -48,9 +48,9 @@ MAKE_FLAGS += \
 	LDFLAGS2="$(TARGET_LDFLAGS)" \
 	IZ_BZIP2="no"
 
-define Package/zip/install
+define Package/infozip/install
 	$(INSTALL_DIR) $(1)/usr/bin/
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
 endef
 
-$(eval $(call BuildPackage,zip))
+$(eval $(call BuildPackage,infozip))
diff --git a/utils/zip/patches/001-unix-configure-borrow-the-LFS-test-from-autotools.patch b/utils/infozip/patches/001-unix-configure-borrow-the-LFS-test-from-autotools.patch
similarity index 100%
rename from utils/zip/patches/001-unix-configure-borrow-the-LFS-test-from-autotools.patch
rename to utils/infozip/patches/001-unix-configure-borrow-the-LFS-test-from-autotools.patch
diff --git a/utils/zip/patches/010-remove-build-date.patch b/utils/infozip/patches/010-remove-build-date.patch
similarity index 100%
rename from utils/zip/patches/010-remove-build-date.patch
rename to utils/infozip/patches/010-remove-build-date.patch
diff --git a/utils/zip/patches/020-format.patch b/utils/infozip/patches/020-format.patch
similarity index 100%
rename from utils/zip/patches/020-format.patch
rename to utils/infozip/patches/020-format.patch