seafile-ccnet: Update to 6.3.4
Switched to codeload for easier package bumping. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
52ca8c9922
commit
0722916ff6
4 changed files with 20 additions and 24 deletions
|
@ -8,16 +8,15 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=seafile-ccnet
|
||||
PKG_VERSION:=6.3.0
|
||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
|
||||
PKG_VERSION:=6.3.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/haiwen/ccnet-server.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=614926b161623b267b4fb77fa1861718da406103
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MIRROR_HASH:=843660e05809e6a6e076cf4d5ea3a6aad65b9b03aa1eaa3b4d980a314e7aed61
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/ccnet-server/tar.gz/v$(PKG_VERSION)-server?
|
||||
PKG_HASH:=ab3d5bda728f87c71929a6247c9f74c5209b9b8e44bafa77db91e8de590ec6ef
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/ccnet-server-$(PKG_VERSION)-server
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
diff -rupN seafile-ccnet-5.1.1.orig/lib/Makefile.am seafile-ccnet-5.1.1/lib/Makefile.am
|
||||
--- seafile-ccnet-5.1.1.orig/lib/Makefile.am 2016-04-21 11:04:46.000000000 +0200
|
||||
+++ seafile-ccnet-5.1.1/lib/Makefile.am 2016-04-22 10:02:52.583732050 +0200
|
||||
--- a/lib/Makefile.am
|
||||
+++ b/lib/Makefile.am
|
||||
@@ -1,3 +1,4 @@
|
||||
+include $(TOPDIR)/rules.mk
|
||||
|
||||
|
@ -20,7 +19,7 @@ diff -rupN seafile-ccnet-5.1.1.orig/lib/Makefile.am seafile-ccnet-5.1.1/lib/Make
|
|||
|
||||
searpc_gen = searpc-signature.h searpc-marshal.h
|
||||
|
||||
@@ -86,7 +87,7 @@ rpc_table.stamp: ${top_srcdir}/lib/rpc_t
|
||||
@@ -86,7 +87,7 @@ rpc_table.stamp: ${top_srcdir}/lib/rpc_table.py
|
||||
@rm -f rpc_table.tmp
|
||||
@touch rpc_table.tmp
|
||||
@echo "[libsearpc]: generating rpc header files"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From afeb62f01ad6e610cd19dcde0ceffc018b3247ec Mon Sep 17 00:00:00 2001
|
||||
From 6c825349e1994a991f287e398cf0ead5f790a01b Mon Sep 17 00:00:00 2001
|
||||
From: Eneas U de Queiroz <cote2004-github@yahoo.com>
|
||||
Date: Wed, 6 Jun 2018 18:05:33 -0300
|
||||
Subject: [PATCH] Remove API deprecated in openssl 1.1
|
||||
|
@ -11,17 +11,17 @@ Also, we need to #include <openssl/bn.h> for BN_num_bytes().
|
|||
|
||||
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
|
||||
---
|
||||
lib/rsa.c | 19 ++++++++++++++-----
|
||||
lib/rsa.c | 15 ++++++++++++---
|
||||
net/common/processors/keepalive-proc.c | 4 ++--
|
||||
net/common/processors/keepalive2-proc.c | 2 +-
|
||||
net/common/processors/sendsessionkey-proc.c | 2 +-
|
||||
net/common/processors/sendsessionkey-v2-proc.c | 2 +-
|
||||
net/server/user-mgr.c | 4 ++++
|
||||
tools/ccnet-init.c | 2 ++
|
||||
7 files changed, 25 insertions(+), 10 deletions(-)
|
||||
7 files changed, 23 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/lib/rsa.c b/lib/rsa.c
|
||||
index 7cca150..23abb82 100644
|
||||
index 7cca150..d969a62 100644
|
||||
--- a/lib/rsa.c
|
||||
+++ b/lib/rsa.c
|
||||
@@ -4,6 +4,7 @@
|
||||
|
@ -39,8 +39,6 @@ index 7cca150..23abb82 100644
|
|||
-
|
||||
- private = RSA_generate_key(bits, 35, NULL, NULL);
|
||||
- if (private == NULL)
|
||||
- g_error ("rsa_generate_private_key: key generation failed.");
|
||||
- return private;
|
||||
+ BIGNUM *e = NULL;
|
||||
+
|
||||
+ private = RSA_new();
|
||||
|
@ -49,11 +47,11 @@ index 7cca150..23abb82 100644
|
|||
+ !RSA_generate_key_ex(private, bits, e, NULL)) {
|
||||
+ RSA_free(private);
|
||||
+ BN_free(e);
|
||||
+ g_error ("rsa_generate_private_key: key generation failed.");
|
||||
g_error ("rsa_generate_private_key: key generation failed.");
|
||||
+ return NULL;
|
||||
+ }
|
||||
+ BN_free(e);
|
||||
+ return private;
|
||||
return private;
|
||||
}
|
||||
diff --git a/net/common/processors/keepalive-proc.c b/net/common/processors/keepalive-proc.c
|
||||
index 609d102..42a0c23 100644
|
||||
|
@ -117,10 +115,10 @@ index c1c6924..4805ba6 100644
|
|||
SHA1_Init (&s);
|
||||
SHA1_Update (&s, random_buf, sizeof(random_buf));
|
||||
diff --git a/net/server/user-mgr.c b/net/server/user-mgr.c
|
||||
index 0973959..3f0c3b3 100644
|
||||
index 8a356f0..7a3f5cb 100644
|
||||
--- a/net/server/user-mgr.c
|
||||
+++ b/net/server/user-mgr.c
|
||||
@@ -811,9 +811,13 @@ hash_password_pbkdf2_sha256 (const char *passwd,
|
||||
@@ -816,9 +816,13 @@ hash_password_pbkdf2_sha256 (const char *passwd,
|
||||
char salt_str[SHA256_DIGEST_LENGTH*2+1];
|
||||
|
||||
if (!RAND_bytes (salt, sizeof(salt))) {
|
||||
|
@ -149,5 +147,5 @@ index 4748962..28c9995 100644
|
|||
if (RAND_status() != 1) { /* it should be seeded automatically */
|
||||
fprintf(stderr, "PRNG is not seeded\n");
|
||||
--
|
||||
2.16.4
|
||||
2.19.1
|
||||
|
||||
|
|
|
@ -34,7 +34,7 @@ define Package/seafile-server
|
|||
DEPENDS:=+libarchive +libopenssl +glib2 +libsearpc +seafile-ccnet +seafile-seahub +sqlite3-cli +python-mysql +python-urllib3 \
|
||||
+jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 +libmysqlclient \
|
||||
+libpthread +libuuid +bash +procps-ng +procps-ng-pkill +SEAFILE_FUSE_SUPPORT:libfuse $(ICONV_DEPENDS)
|
||||
EXTRA_DEPENDS:=seafile-ccnet (=6.3.0-614926b161623b267b4fb77fa1861718da406103-1), seafile-seahub (=6.3.0-d1ab146a936a6ea1e1581bf3f194e86742f0d3cd-1)
|
||||
EXTRA_DEPENDS:=seafile-seahub (=6.3.0-d1ab146a936a6ea1e1581bf3f194e86742f0d3cd-1)
|
||||
MENU:=1
|
||||
endef
|
||||
|
||||
|
|
Loading…
Reference in a new issue