mjpg-streamer: Upgrade to r182-experimental, add patches to remove debug, build additional plugins and minor fixes.
Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
ad886cf1f4
commit
071481e626
4 changed files with 64 additions and 4 deletions
|
@ -8,17 +8,16 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mjpg-streamer
|
||||
PKG_REV:=181
|
||||
PKG_REV:=182
|
||||
PKG_VERSION:=r$(PKG_REV)
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://svn.code.sf.net/p/mjpg-streamer/code/mjpg-streamer
|
||||
PKG_SOURCE_URL:=https://svn.code.sf.net/p/mjpg-streamer/code/mjpg-streamer-experimental
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
PKG_MD5SUM:=b2bc22665733319e647ace236e283684
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
PKG_LICENSE_FILE:=LICENSE
|
||||
|
|
|
@ -0,0 +1,17 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -33,12 +33,12 @@ APP_BINARY = mjpg_streamer
|
||||
|
||||
# define the names and targets of the plugins
|
||||
PLUGINS = input_uvc.so
|
||||
-#PLUGINS += output_file.so
|
||||
+PLUGINS += output_file.so
|
||||
#PLUGINS += output_udp.so
|
||||
PLUGINS += output_http.so
|
||||
PLUGINS += input_testpicture.so
|
||||
#PLUGINS += output_autofocus.so
|
||||
-#PLUGINS += input_file.so
|
||||
+PLUGINS += input_file.so
|
||||
# PLUGINS += input_pylon.so
|
||||
# PLUGINS += input_megatec.so
|
||||
# PLUGINS += output_mars2020.so
|
|
@ -0,0 +1,33 @@
|
|||
--- a/plugins/input_uvc/Makefile
|
||||
+++ b/plugins/input_uvc/Makefile
|
||||
@@ -13,7 +13,7 @@ OTHER_HEADERS = ../../mjpg_streamer.h ..
|
||||
|
||||
CFLAGS += -O1 -DLINUX -D_GNU_SOURCE -Wall -shared -fPIC
|
||||
|
||||
-CFLAGS += -g -DDEBUG
|
||||
+#CFLAGS += -g -DDEBUG
|
||||
|
||||
ifeq ($(USE_LIBV4L2),true)
|
||||
LFLAGS += -lv4l2
|
||||
--- a/plugins/output_file/Makefile
|
||||
+++ b/plugins/output_file/Makefile
|
||||
@@ -12,7 +12,7 @@ CC = gcc
|
||||
OTHER_HEADERS = ../../mjpg_streamer.h ../../utils.h ../output.h ../input.h
|
||||
|
||||
CFLAGS += -O2 -DLINUX -D_GNU_SOURCE -Wall -shared -fPIC
|
||||
-CFLAGS += -DDEBUG -g
|
||||
+#CFLAGS += -DDEBUG -g
|
||||
LFLAGS += -lpthread -ldl
|
||||
|
||||
all: output_file.so
|
||||
--- a/plugins/output_udp/Makefile
|
||||
+++ b/plugins/output_udp/Makefile
|
||||
@@ -14,7 +14,7 @@ CC = gcc
|
||||
OTHER_HEADERS = ../../mjpg_streamer.h ../../utils.h ../output.h ../input.h
|
||||
|
||||
CFLAGS += -O2 -DLINUX -D_GNU_SOURCE -Wall -shared -fPIC
|
||||
-CFLAGS += -DDEBUG
|
||||
+#CFLAGS += -DDEBUG
|
||||
LFLAGS += -lpthread -ldl
|
||||
|
||||
all: output_udp.so
|
|
@ -0,0 +1,11 @@
|
|||
--- a/plugins/input_uvc/v4l2uvc.c
|
||||
+++ b/plugins/input_uvc/v4l2uvc.c
|
||||
@@ -69,7 +69,7 @@ int init_videoIn(struct vdIn *vd, char *
|
||||
vd->videodevice = (char *) calloc(1, 16 * sizeof(char));
|
||||
vd->status = (char *) calloc(1, 100 * sizeof(char));
|
||||
vd->pictName = (char *) calloc(1, 80 * sizeof(char));
|
||||
- snprintf(vd->videodevice, 12, "%s", device);
|
||||
+ snprintf(vd->videodevice, 16, "%s", device);
|
||||
vd->toggleAvi = 0;
|
||||
vd->getPict = 0;
|
||||
vd->signalquit = 1;
|
Loading…
Reference in a new issue