Merge pull request #5240 from ecsv/ap51-flash
ap51-flash: Update to newest "version" and package cleanups
This commit is contained in:
commit
05cee96008
2 changed files with 6 additions and 30 deletions
|
@ -7,23 +7,21 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ap51-flash
|
||||
PKG_VERSION:=2016-10-16
|
||||
PKG_VERSION:=2017-12-07
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://dev.cloudtrax.com/ap51-flash.git
|
||||
PKG_SOURCE_URL:=https://github.com/ap51-flash/ap51-flash.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=48b3fbac1c30c5968b2608eb09b53ea37c310a24
|
||||
PKG_SOURCE_VERSION:=f94f9c99711d14a3c0186318d822d67d9d0ce391
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
|
||||
PKG_MIRROR_HASH:=4d00a1ceb480793db95e359cb95d63630920335415c7ffdcd05f2616cf1bc034
|
||||
PKG_MIRROR_HASH:=15786a0ecae9be5ed4e8f32940624d1a1c83da924294df08003616a863947074
|
||||
PKG_MAINTAINER:=Russell Senior <russell@personaltelco.net>
|
||||
PKG_LICENSE:=GPL-3.0+
|
||||
PKG_LICENSE_FILES:=LICENSES/preferred/GPL-3.0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
ifeq ($(CONFIG_BIG_ENDIAN),y)
|
||||
STAMP_BUILT:=$(STAMP_BUILT)_big
|
||||
endif
|
||||
|
||||
define Package/ap51-flash
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
|
@ -31,15 +29,8 @@ define Package/ap51-flash
|
|||
URL:=http://dev.cloudtrax.com/wiki/ap51-flash-station
|
||||
endef
|
||||
|
||||
TARGET_EXTRA_CFLAGS:=-DFLASH_FROM_FILE -DNO_LIBPCAP -D_GNU_SOURCE
|
||||
ifeq ($(CONFIG_BIG_ENDIAN),y)
|
||||
TARGET_EXTRA_CFLAGS:=$(TARGET_EXTRA_CFLAGS) -DUIP_CONF_BYTE_ORDER=1234
|
||||
endif
|
||||
|
||||
# pass optimization flags
|
||||
MAKE_FLAGS += \
|
||||
OFLAGS="$(TARGET_CFLAGS)" \
|
||||
EXTRA_CFLAGS="$(TARGET_EXTRA_CFLAGS)" \
|
||||
REVISION="$(PKG_VERSION)" \
|
||||
ap51-flash
|
||||
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
Index: ap51-flash-2016-10-16/proto.c
|
||||
===================================================================
|
||||
--- ap51-flash-2016-10-16.orig/proto.c
|
||||
+++ ap51-flash-2016-10-16/proto.c
|
||||
@@ -29,6 +29,10 @@
|
||||
#include "router_redboot.h"
|
||||
#include "router_tftp_client.h"
|
||||
|
||||
+#ifndef IPPORT_TFTP
|
||||
+#define IPPORT_TFTP 69
|
||||
+#endif
|
||||
+
|
||||
#define TFTP_SRC_PORT 13337
|
||||
#define REDBOOT_TELNET_SPORT 13337
|
||||
#define REDBOOT_TELNET_DPORT 9000
|
Loading…
Reference in a new issue