From 04e52a13c4feee567dcc8fb7b1201a40b26d88cd Mon Sep 17 00:00:00 2001
From: Florian Eckert <fe@dev.tdt.de>
Date: Wed, 28 Oct 2020 15:56:21 +0100
Subject: [PATCH] simple-adblock: use new extra_command function definition

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---
 net/simple-adblock/Makefile                  |  2 +-
 net/simple-adblock/files/simple-adblock.init | 11 +++++------
 2 files changed, 6 insertions(+), 7 deletions(-)

diff --git a/net/simple-adblock/Makefile b/net/simple-adblock/Makefile
index 35a9f0f25..aaa9753b4 100644
--- a/net/simple-adblock/Makefile
+++ b/net/simple-adblock/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=simple-adblock
 PKG_VERSION:=1.8.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
 PKG_LICENSE:=GPL-3.0-or-later
 
diff --git a/net/simple-adblock/files/simple-adblock.init b/net/simple-adblock/files/simple-adblock.init
index ba2a597e8..0c04998ec 100644
--- a/net/simple-adblock/files/simple-adblock.init
+++ b/net/simple-adblock/files/simple-adblock.init
@@ -10,12 +10,11 @@ USE_PROCD=1
 LC_ALL=C
 
 # shellcheck disable=SC2034
-EXTRA_COMMANDS='check dl killcache sizes show version'
-# shellcheck disable=SC2034
-EXTRA_HELP='	check	Checks if specified domain is found in current block-list
-	dl	Force-downloads all enabled block-list
-	sizes	Displays the file-sizes of enabled block-lists
-	show	Shows the service last-run status'
+extra_command "check" "Checks if specified domain is found in current block-list"
+extra_command "dl" "Force-downloads all enabled block-list"
+extra_command "sizes" "Displays the file-sizes of enabled block-listo"
+extra_command "show" "Shows the service last-run status"
+extra_command "version" "Show version"
 
 readonly packageName='simple-adblock'
 readonly serviceName="$packageName $PKG_VERSION"