squid: update to 3.5.12
Signed-off-by: Mislav Novakovic <mislav.novakovic@sartura.hr>
This commit is contained in:
parent
6650c96833
commit
04d79438d2
2 changed files with 30 additions and 30 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=squid
|
||||
PKG_VERSION:=3.5.9
|
||||
PKG_VERSION:=3.5.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
@ -16,7 +16,7 @@ PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
|||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.squid-cache.org/Versions/v3/3.5/
|
||||
PKG_MD5SUM:=fe7306a90a0ba2fc906e9a8c741cc8ea
|
||||
PKG_MD5SUM:=50016bf6e2d3a3a186a6c7236d251f63
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
@ -33,7 +33,7 @@ endef
|
|||
define Package/squid
|
||||
$(call Package/squid/Default)
|
||||
MENU:=1
|
||||
DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp +libgnutls
|
||||
DEPENDS:=+libopenssl +libpthread +librt +libltdl +libstdcpp
|
||||
TITLE:=full-featured Web proxy cache
|
||||
endef
|
||||
|
||||
|
@ -62,12 +62,8 @@ CONFIGURE_ARGS += \
|
|||
--enable-kill-parent-hack \
|
||||
--disable-snmp \
|
||||
--enable-ssl \
|
||||
--enable-ssl-crtd \
|
||||
--enable-cache-digests \
|
||||
--enable-auth \
|
||||
--enable-auth-basic \
|
||||
--enable-auth-ntlm \
|
||||
--enable-auth-negotiate \
|
||||
--enable-auth-digest \
|
||||
--enable-linux-netfilter \
|
||||
--disable-unlinkd \
|
||||
--enable-x-accelerator-vary \
|
||||
|
@ -77,6 +73,7 @@ CONFIGURE_ARGS += \
|
|||
--with-pthreads \
|
||||
--without-expat \
|
||||
--without-libxml2 \
|
||||
--without-gnutls \
|
||||
--without-nettle \
|
||||
--with-openssl=$(STAGING_DIR)/usr \
|
||||
--enable-epoll \
|
||||
|
@ -89,16 +86,16 @@ CONFIGURE_ARGS += \
|
|||
--disable-arch-native \
|
||||
--with-krb5-config=no \
|
||||
--without-libcap \
|
||||
--without-netfilter-conntrack \
|
||||
--without-netfilter-conntrack
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_header_linux_netfilter_ipv4_h=yes \
|
||||
ac_cv_epoll_works=yes \
|
||||
squid_cv_gnu_atomics=no
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/lib \
|
||||
all
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR)/lib all
|
||||
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install
|
||||
endef
|
||||
|
@ -107,6 +104,9 @@ define Package/squid/install
|
|||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/squid $(1)/usr/sbin/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/squid
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/squid/ssl_crtd $(1)/usr/lib/squid
|
||||
|
||||
$(INSTALL_DIR) $(1)/etc/config
|
||||
$(INSTALL_CONF) ./files/squid.config $(1)/etc/config/squid
|
||||
|
||||
|
|
|
@ -1,24 +1,24 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -20208,3 +20208,3 @@ if test "$cross_compiling" = yes; then :
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
+_as_fn_error $? "cannot run test program while cross compiling
|
||||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
@@ -28364,3 +28364,3 @@ else
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
+_as_fn_error $? "cannot run test program while cross compiling
|
||||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
@@ -28389,3 +28389,3 @@ else
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
+_as_fn_error $? "cannot run test program while cross compiling
|
||||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -7980,3 +7980,3 @@ cache_cf.o: cf_parser.cci
|
||||
@@ -7761,3 +7761,3 @@ cache_cf.o: cf_parser.cci
|
||||
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
|
||||
- $(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
||||
+ g++ -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
||||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -20133,3 +20133,3 @@ if test "$cross_compiling" = yes; then :
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
+_as_fn_error $? "cannot run test program while cross compiling
|
||||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
@@ -28289,3 +28289,3 @@ else
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
+_as_fn_error $? "cannot run test program while cross compiling
|
||||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
@@ -28314,3 +28314,3 @@ else
|
||||
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "cannot run test program while cross compiling
|
||||
+_as_fn_error $? "cannot run test program while cross compiling
|
||||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
|
|
Loading…
Reference in a new issue